Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2001
    Location
    Cincinnati, OH
    Posts
    6

    Unanswered: combo box fills subform data not main form

    I have a combo box that is used to find the data from 2 tables, a Master and a Detail. After I enter the key value into the combo box, it retrieves the data from the Detail table and places it into the subform. Apparently it does not retrieve data from the Master table since that part of the main form is blank, except for the textbox that shows the master key value.

    Here is the code that was generated from the wizard:

    Sub cboLookup_AfterUpdate()
    ' Find the record that matches the control.
    Me.RecordsetClone.FindFirst "[ID] = " & Me![cboLookup]
    Me.Bookmark = Me.RecordsetClone.Bookmark
    End Sub

    What could be causing this phenomenon?

    TIA

    Ray

  2. #2
    Join Date
    Feb 2002
    Posts
    403
    Try adding Me.requery after the wizard code. it would go just before the end sub.

    Alternatively you could move the cboLookup combo box to the form header.

  3. #3
    Join Date
    Sep 2001
    Location
    Cincinnati, OH
    Posts
    6
    I tried both the Me.ReQuery command and moving the combo box to the form header and to the form trailer with no success. A Find box created via the wizard gives the message "You can't use Find or Replace now".

    Ray

  4. #4
    Join Date
    Feb 2002
    Posts
    403
    Please zip and upload as little of your database as you can that shows exactly what you need.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •