I have various command buttons in order to mail various reports which were working perfectly. (Using Acc '97)

Now I get varying errors. One of them says:

”This recordset is not updateable.”
Another two say:

”Training Database can’t find the name “Enter Month Range for Title” / “Enter TrainerID” you entered in the expression.

You may have specified a control that wasn’t on the current object without specifying the correct form or report context.

To refer to a control on another form or report, precede the control name with the name of a collection, usually either Forms or Reports and the name of the form or report to which the control belongs. For example, Forms![Products]![UnitsInStock].”
I am able to open the reports, just to view them, and they work fine. Also, if I send it to .rft format, there’s no problem, but obviously lose all the formatting. I did try putting parameters in a query in another database that I had SendObject already set up for, and it worked ok, so it's something to do with the database. I converted it to Acc 2000 and it worked fine, so I tried converting it back but the problem was still there.

Anyone got any ideas please?