Results 1 to 6 of 6
  1. #1
    Join Date
    Jun 2002
    Posts
    1

    Unanswered: ora : 27123 Unable to attach to shared memory segment

    Hi All,

    I am installing oracle 9.0.2.1 on red hat linux 7.3. My server configuration is P4 256MB RAM, 20GB Barracuda HDD.
    While installing, it gave me ora: 27123 error. Swap partition for the system is 2GB. All the necessary previledges of filesystem are given to oracle user.

    Please help me.

    Thanks in advance.

    Regards

    Abhay

  2. #2
    Join Date
    Apr 2001
    Location
    Netherlands
    Posts
    191
    The error means it cannot get enough shared memory.
    Please check the kernel parameters, mentioned in the installation manual.
    (SHMSEG etc)
    It might be that these parameters need tuning, or you just need more mem.

    Ruud
    Ruud Schilders
    -----------------
    Oracle DBA
    e-mail : ruud@schilders.it
    URL : www.schilders.it
    Twitter : www.twitter.com/ruudschilders

  3. #3
    Join Date
    Sep 2002
    Location
    NJ
    Posts
    139

    ORA-27123: unable to attach to shared memory segment

    hi,

    I got the same problem, but my shared memory seems ok. What else could I do??


    ORA-27123: unable to attach to shared memory segment
    SVR4 Error: 24: Too many open files

    set shmsys:shminfo_shmmax=8388608
    set shmsys:shminfo_shmmin=1
    set shmsys:shminfo_shmmni=100
    set shmsys:shminfo_shmseg=10
    set semsys:seminfo_semmni=100
    set semsys:seminfo_semmsl=100
    set semsys:seminfo_semmns=200
    set semsys:seminfo_semopm=100
    set semsys:seminfo_semvmx=32767


    What does "too many open files" mean in this context?

  4. #4
    Join Date
    Apr 2003
    Location
    Bangalore (India)
    Posts
    2

    Shared Memory Problem..Check your ORACLE_SID

    Hi Abhay,
    Not sure how much help this can be of to you.. While installing Oracle 9.0.2.1 on Solaris 8, I also faced the same problem.

    First, I tried setting the Shared Memory parameters in the '/etc/system' file.

    Second, I checked all the init files of the oracle for the value set for the ORACLE_SID and the ORACLE_HOME. In my case, there were some places where there was a case mismatch...

    So, check your ORACLE_SID and ORACLE_HOME values...force it in your ".profile" to take the correct values...

    Let me know if this works...

    Regards
    Bharathan (bharathanv@epatra.com)

  5. #5
    Join Date
    Mar 2003
    Posts
    45
    Hi,

    I checked my init file and found that my
    SHARED_POOL_SIZE=31457280
    DB_BLOCK_SIZE=5936
    SHMMAX=8388608

    The SHARED_POOL_SIZE is too big: how do I change it correctly? Please not I am not able to start the instance at this point and the formula used to figure out the shared_pool_size vis as vis the db_block_size is not available since I can not access "block size"

  6. #6
    Join Date
    Apr 2002
    Location
    California, USA
    Posts
    482

    Smile

    Your DB_BLOCK_SIZE can have 2048, 4096, 8192, etc. values. Why are you using 5936? Any reason to do that?

    And your shared is not so big, for your 256 Mb RAM. You can follow the rule that the value of the kernel parameter "shmmax" is at least 10% bigger than the estimated size of the SGA of for database.

    Post your init.ora file to see the rest of the parameters - PROCESSES, data buffer cache, etc.


    Hope that helps,

    clio_usa - OCP - DBA


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •