Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2002
    Posts
    2

    Question Unanswered: Missing data from SELECT statement

    I've run across this before, but only in a table with a BLOB. I've selected half-a-dozen fields from a table, and one comes back as empty even though it's not. Putting in some code to debug, right after I read in the recordset the data is there, but when I try to use it later it disappears, even though moveNext hasn't been called and the recordset has not been updated in any way.

    foo = rs("theValue")

    ...

    if foo <> rs("theValue") then msgbox "db error"
    ' pops up db error every time


    I'm concerned that this may be causing a problem that hasn't been caught yet. Does anyone here know anything about what causes this that would be helpful in avoiding it? I'm about to look for later drivers, but I couldn't find anything about this on MS's site.

    I'm running NT4000.1381 w/ SQL driver 2000.80.380.00 (SQLSRV32.DLL 4/11/01)

    Thanks!

  2. #2
    Join Date
    Jun 2002
    Posts
    18
    what fields definitions do you have. This happens to me loads with incorrect fields data types.

  3. #3
    Join Date
    Jun 2002
    Posts
    2
    int, char not-nulable
    int, char, datetime, varchar nullable

    The value in question is a nullable char 10 that generally has 5 characters. There are no joins to bring anything odd into the mix.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •