I am sorry the link to your post is not working and hence I have put a new post.
It appears that the character-set of your database is incorrect. You should either set the character-set to either unicode (e.g. UTF-8) or some Korean character-set (since you are trying to enter korean text).

The 3 ways to set the character-set is:
1. Alter the character-set of the database
2. When creating a new database chose the "custom creation" option and select the "character-set" and "national charcater-set" according to your needs.
3. When creating a new database set NLS_LANG variable appropriately (unicode or Korean) and do a "default creation". Since your NLS_LANG is set to WE8ISO8859P1 presently, it will only allow you to enter Latin-1 characters only in varchar2 columns. (I presume the database involved was created with NLS_LANG set to this value itself)

Hope this helps. Do get back to me in case of further queries.