Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2002
    Location
    Boston, MA
    Posts
    2

    Unanswered: Why isn't data in my form automatically populating?

    Hi guys,

    I have a quick question that will probably be simple to answer, but I can't see what I'm doing wrong.

    When I create a new form, I include fields from my three different tables, tbl_ED, tbl_CN, and tbl_SI (my main table). These tables are all related to each other in the "relationships" area and therefore, the fields should automatically populate with data that has already been entered in previous forms. But no such luck. When I combine tables tbl_ED and tbl_SI, it works fine, so the probably seems to be with tbl_CN. I have attached a diagram of my relationships to show the setup.

    I hope someone can help! Thank you in advance.

    -Awais
    Attached Thumbnails Attached Thumbnails relationships.bmp  

  2. #2
    Join Date
    Jul 2002
    Location
    Boston, MA
    Posts
    2

    addendum

    Just a note that the table I referred to as tbl_SI is the abbreviation for tbl_Software_Item.

  3. #3
    Join Date
    Jul 2002
    Posts
    4
    Have you considered using a select box and then using the "column()" function to populate the rest of the fields? You create a combo select box using a query to populate the select fields. The query for the combo box has multiple fields, but you only display one for the select box. Then you use the column function to populate the other fields in your form with the other fields from your combo box query.

  4. #4
    Join Date
    Jul 2002
    Location
    Australia
    Posts
    147
    How many records does it show in the query that is the source of the form.

    Cheers,
    Andrew
    There have been many posts made throughout the world.
    This was one of them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •