Results 1 to 11 of 11

Thread: -952 Error

  1. #1
    Join Date
    Jul 2002
    Location
    Parkersburg, WV
    Posts
    5

    Unhappy Unanswered: -952 Error

    I am having a problem connecting through ODBC to a Informix SE 7.2 engine. I am getting the following error.
    "[Informix][ODBC Driver][Informix] user "%S" password is not correct for the database server." - on the ODBC side.
    "Daemon err=-952: users password is not correct for the database server." - on the database side.
    The server is a linux box based on redhat 6.2. and I have never connected to this server before via ODBC.

    Any help would be apreciated.

  2. #2
    Join Date
    Feb 2002
    Posts
    2,232
    Which user id are you using ? How long is the password ? Can you access Informix if you login into linux directly using dbaccess / onstat commands ? Also, look at your release notes. Which version of informix are you running - include uc version ?
    Last edited by rnealejr; 07-22-02 at 23:45.

  3. #3
    Join Date
    Jul 2002
    Location
    Parkersburg, WV
    Posts
    5
    I am using the informix user id. and the password is 6 charaters long.
    when logged on locally I have no problem accessing the database with dbaccess. And I am running Informix-SE 7.24 UC5.

    thanks for helping.

  4. #4
    Join Date
    Feb 2002
    Posts
    2,232
    I believe this is a known bug with uc5 and the fix is in uc8 - I will let you know what I am able to find out.

  5. #5
    Join Date
    Feb 2002
    Posts
    2,232
    Yes, I was correct. You need to upgrade to uc8. Good luck.

  6. #6
    Join Date
    Jul 2002
    Location
    Parkersburg, WV
    Posts
    5
    Thank'sfor the info.
    As a temporary solution will seting the system to not use shadow passwords work?
    Maybe having the full answer here will help someone else.

  7. #7
    Join Date
    Feb 2002
    Posts
    2,232
    The 952 error can be caused by many issues - one of which is the passwords being shadowed - however, I would never recommend unshadowing your passwords because it is such a serious security threat. If you proceed, let me know if it fixes your problem - if not, there might be other solutions - but I strongly urge you not to monkey with the shadowing. I would give you examples of MAYBE when this would be ok but you would have to check (now and constantly monitor) several exploits that this would enable and make sure that your box is locked down.

  8. #8
    Join Date
    Jul 2002
    Location
    Parkersburg, WV
    Posts
    5
    I have unshadowed the passwords and it allows me to test the odbc connection, and see the table names in access 2000. However when I try to link to any of these tables I am getting :
    Reserved error (-7711) There is no message for this error.

    I intend to change the version of informix we are on to allow shadow passwords again.

  9. #9
    Join Date
    Jul 2002
    Location
    Parkersburg, WV
    Posts
    5
    The -7711 message is from my laptop ( must be setup wrong).
    I have the problem solved.
    Thank you for your help!

  10. #10
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    Be aware if you upgrade to 7.25.UC1. You MUST have password shadowing enabled.
    They tried to fix the bug...
    rws

  11. #11
    Join Date
    Jan 2003
    Posts
    1

    Re: -952 Error

    hi,
    i read this post just now. I got the same problem with informix 7.24 UC5.
    But even worse, i could not even login with dbaccess. So is there any way i can solve it without upgrate UC5 to UC8?

    Thanks.

    Originally posted by pklucas
    I am having a problem connecting through ODBC to a Informix SE 7.2 engine. I am getting the following error.
    "[Informix][ODBC Driver][Informix] user "%S" password is not correct for the database server." - on the ODBC side.
    "Daemon err=-952: users password is not correct for the database server." - on the database side.
    The server is a linux box based on redhat 6.2. and I have never connected to this server before via ODBC.

    Any help would be apreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •