Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2002
    Posts
    3

    Post Unanswered: Any way to Link to Foxpro in read/write mode?

    I used to have a real handy Access application that could write/update fields in a Foxpro DB. Now with Access 2002 we have to use ODBC to link, and it's read only (as far as I can tell). Is there any way to link to a Foxpro DB table, and be able to link to it with all the same write functions as a normal Access table? (Exporting won't do, I need to append and update by a query statement).

  2. #2
    Join Date
    Nov 2001
    Posts
    336
    Hi,

    Old ODBC should work. Have you tried it?

    Igor

  3. #3
    Join Date
    Feb 2002
    Posts
    403
    I have worked in Foxpro from access and all we did was linked as you have done. To run my queries I copied the data out to a new table, worked on the data and then ran an update to the Foxpro table.

    If you cannot write to the foxpro table have you got the relevant permissions?

  4. #4
    Join Date
    Jul 2002
    Location
    Romania
    Posts
    122
    That's exactly my frustration with Access 2000 and XP. We have a FoxPro system on the network and I've been using Access 97 to work with linked FoxPro tables.
    Wanted to upgrade to Access 2000, did so and surprisingly, the Access application wouldn't work anymore. Tried ODBC, but got everything read-only and so slow that I had to shave myself everytime after opening one simple table.
    Wanted to extend the MS license, and found out only XP was available. Upgraded to XP and had the same problem.
    So I'm back to old reliable Access 97.
    But I'd really like to find some installable ISAM's for 2K and XP so that I can take advantage of ADO instead of DAO.



    Dan

  5. #5
    Join Date
    Jul 2002
    Posts
    3
    The only driver I note on my PC is a MS Visual Foxpro version 6.01.8629.01, & the file is VFPODBC.DLL dated 12/7/99. I looked for an an earlier one on the MS support downloads site, and noticed that they have a ODBC v2.0 driver pack, but their link doesn't work. I also tried to copy in the VFPODBC.DLL from my Win 98 laptop (it was dated only a couple months earlier) but I don't think my system allowed the copy function (it looked like it copied, but the original file date/time stamp was still on the file after it completed).

    I work with other files in the same folder with no problem, so I do have access privilieges to the folder, and the securities properties of the table files are set to both read, and write. So unless I'm missing something, it looks like it should give me access.

    Even if I import the data, work it, then try to export back to foxpro, I get an error message that says that the string is too long. So that doesn't seem to work for me either.

    If you have any other ideas, or, know how to get an older driver installed, I'd love to hear it.

    Thanks

  6. #6
    Join Date
    Aug 2002
    Posts
    1
    I have the same problem

    Finally , I found this :

    Ms KB Q290867 --using dBase tables with Access 2002 -

    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q290867

    and it seemed to be the answer.



    Ema

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •