Results 1 to 2 of 2
  1. #1
    Join Date
    Jul 2002

    Post Unanswered: error ORA-02041 when using dblink on ODBC

    Hi to everybody....

    I got a problem trying to use an Oracle DBLINK into an Visual Basic aplication conected by ODBC. When i run a Stored procedure from the SQL + i works, but when I try to run from my app I got this error:

    ORA-02041 client database did not begin a transaction

    Do I have to do something on the ODBC configuration ?? or do I need any special parameter ..????'

    Thanx !!


  2. #2
    Join Date
    Aug 2003

    error ORA-02041 when using dblink on ODBC

    I had the same problem. I went to the ODBC Control Panel and selected to configure my connection. On this screen a tab appears. One of the tabs is "workarounds" where I checked "Disable Microsoft Transaction Server" (everything else is unchecked).

    Now it works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts