Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2002
    Location
    Canada
    Posts
    8

    Red face Unanswered: Data Entry: what is up with my brain?

    So I have copied the code for all these forms for a multitude of databases that I am converting from Access 97/95 to Access xp. They work in 97 but I am missing some crucial element in the design or something of them and they are not allowing any input. Those that are designed to go to a specific record in a table on open or activate or load are giving the error "Can't go to specified record" and others just don't allow any data to be input or any selections to be made. I know this is some basic design of form thing that I am missing but I don't know what. HELP HELP HELP. Brain surgery is next. Ack!

  2. #2
    Join Date
    Jun 2002
    Location
    Mpls/St.Paul area
    Posts
    303
    Did you design the forms or write the code for the Access 97 DB?
    John
    This is the day the Lord has made, I will rejoice and be glad in it.

  3. #3
    Join Date
    Jul 2002
    Location
    Canada
    Posts
    8

    Question Well...

    Thanks for responding John:
    I designed the forms to LOOK exactly as the old ones (or more or less the same) and set the bound controls as best I could see they were set in the old ones, renamed everything exactly as the old ones, changed the references to DAO3.6 and then copied the code. There are no compile errors but there are occassional run time errors saying that I can't go to that record (whatever the code sets as the focus) and when I try to enter data either it just doen'st show at all in the text box or in a combo box it doesn't get selected. So they look great, open and close as the should but do absolutely nothing. THe comboboxes do fill according to how they are bound. I wonder if there isn't just some enabling property that I haven't set. Whatever it is I am very consistent with it.
    Any ideas?

  4. #4
    Join Date
    Jul 2002
    Location
    Canada
    Posts
    8
    I am now noticing that as I create forms that print records that the printing does not happen either. Again no error messages just no printing. I wonder if I need to recreate the records (which are now stored locally while tables are external) and queries. Or can I store the records and queries externally as well.
    Hmmm: this started out as such a simple thing...HAH!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •