Gurus..

I have a technical issue related to Progress database running on IBM

One of our client in Colombo are using Progres DB on NT in Netfinity server currently.
They bought an IBM e-server 360 model recently and trying to run the same Progress DB,
now on Windows 2000 in the new server. When you increase the no of users, a
database (could be any) gets disconected from the server,particularly on one
application. This problem they do not have on NT. they incresed the user
licences but still have the same problem. What could be the reason as you
see it with the little info I gave above.. Below is the error log generated...
It is...

Progress Error code : 1157
Error message : Broker could not spawn a server.
Description : In the shared memory networking model of Progress, the broker
was trying to spawn a server and the spawned process died before it had a
chance to notify the broker that it was alive. This can happen for any
number of reasons - the host machine could be out of available processes or
available ports or network connection points or the shared memory versions
between broker and server do not match or there are not enough semaphores
for the new server etc.

The progress version : 9.0B (Currently running with NT)
: 9.1D (upgraded version for Windows 2000)

On both versions the same error appeared.
Please note we have simulated the same setup (Windows 2000 and Progress DB)
on an independent PC network and found that same error is appearing when
number of users are incresed (well below the licensed number).

Thanking you for the kind assitance in this regard.