Results 1 to 2 of 2
  1. #1
    Join Date
    Aug 2002
    Posts
    1

    Unanswered: SQLDMO and SQL Agent?

    hi,

    I'm hoping that someone can help me out with the problem I'm having with my MS SQL Server (2000). My problem is the following:

    Every time I execute SQL Agent job from ASP page, it creats a banch of processes under Process Info in SQL Server Enterprise Manager. All the processes created by SQL Agent have "exec msdb..sp_help_job" in them and they sit there doing nothing. Next time another SQL Agent job is executed, other banches are entered, and so on. Those processes never get cleaned up so that the SQL Server is eventually filled with banch of processes. When I execute Agent jobs from ASP, I explictly open and close the connection but it seems not helping. Is there any way I can clean up those processes once they are executed?

    Thanks in advance,
    kerroppa

  2. #2
    Join Date
    Nov 2003
    Posts
    1

    Re: SQLDMO and SQL Agent?

    Kerroppa,

    Did you ever hear back from anyone on this issue? I'm having a somewhat similar issue with sql agent jobs in sql server 2000. I have some DB Mainenance jobs that keep hanging. I stop the jobs, but their proccesses stay in the process info screen after and when the maintence jobs start again, it just creates another set of processes. Do you know how I can get these cleaned up?

    Thank you.

    -Doug

    Originally posted by kerroppa
    hi,

    I'm hoping that someone can help me out with the problem I'm having with my MS SQL Server (2000). My problem is the following:

    Every time I execute SQL Agent job from ASP page, it creats a banch of processes under Process Info in SQL Server Enterprise Manager. All the processes created by SQL Agent have "exec msdb..sp_help_job" in them and they sit there doing nothing. Next time another SQL Agent job is executed, other banches are entered, and so on. Those processes never get cleaned up so that the SQL Server is eventually filled with banch of processes. When I execute Agent jobs from ASP, I explictly open and close the connection but it seems not helping. Is there any way I can clean up those processes once they are executed?

    Thanks in advance,
    kerroppa

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •