Results 1 to 7 of 7
  1. #1
    Join Date
    Aug 2002
    Posts
    3

    Unhappy Unanswered: -952 error on aix

    help! help!
    Users can connect without problems, but IDS generates -952 errors in the message log from time to time (10s times ).restart the engine,everything is ok! but two days later,-952 errors is again

    IDS 7.31.UC5 AIX 4.3.3 ML-10

    Thanks

  2. #2
    Join Date
    Aug 2002
    Posts
    3

    somebody can help me?

    somebody can help me?

  3. #3
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    Don't panic, I'm checking...
    rws

  4. #4
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    Who is the owner/group of the oninit process?
    Who is the owner/group of the oninit file?
    I think in this case you need root...
    rws

  5. #5
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    Check out this one:

    Bug: 151445 951 AND 952 ERRORS ON AIX 4.3.3 RELEASE LEVEL 08 DUE TO MEMORY
    LEAK IN GETPWNAM() CALL

    caused by AIX 4.3.3 level 08...

    Description:
    On aix 4.3.3 release 08 there is a memory leak in the getpwnam()
    system call that will result in the growth of the msc vp's heap.
    Once it reaches the default limit of 256 MB we start returning 951 or
    952 errors.

    To see what release level you are at run:

    instfix -i | grep AIX_ML

    look for:

    All filesets for 4330-08_AIX_ML were found.
    rws

  6. #6
    Join Date
    Aug 2002
    Posts
    3

    thanks Roelwe

    thanks very much , Roelwe
    the owner/group of the oninit process and onint files is informix
    my aix is AIX 4.3.3 level 10
    as your said "there is a memory leak in the getpwnam()
    system call that will result in the growth of the msc vp's heap."
    is that means if I use 'onstat -g glo' to find the vp msc and monitor it
    the memory of msc vp will growing,this will take my a few day to find errors.
    thanks again very much!

  7. #7
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    hi,

    since you are on level10, I don't think that this bug wil be the case. Try to set root as the owner of oninit and see what it does. Try to startup ids with root and check what it does...
    rws

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •