Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2002

    Unanswered: Upload a blob in Sybase

    I've a problem, when I want to make a AppendChunk in sybase with a file bigger 400Kb. The problem it's:

    "There is not enough procedure cache to run this procedure, trigger, or SQL batch. Retry later, or ask your SA to reconfigure SQL Server with
    more procedure cache."

    I've changed the cache size, but I've the same problem when the file that I've is bigger 400 Kb.

    Someone know how can I solvent this problem?


  2. #2
    Join Date
    Mar 2001
    Lexington, KY
    What version of ASE?


  3. #3
    Join Date
    Sep 2002
    Originally posted by MattR
    What version of ASE?

  4. #4
    Join Date
    May 2003
    It would appear I see the same problem when inserting
    a image/text/blob. I don't see the error when the
    amount of data is smaller. I don't have specifics
    on the size of data inserting since I recently encountered
    the problem.

    procedure cache size is set to an abnormally high 80%.
    The DYNAMIC_PROCEDURE jdbc option is set to false.

    I'm not sure what db version, but it isn't the latest. I
    think it is v11 if that makes sense. (I'm not a dba.)

    I read somewhere that the problem may be related
    to the network settings. I have no clue what the optimal
    settings would be for the data I need to insert, nor do I
    know what other affects such changes would have on other
    areas of the problem.

    Current settings:
    Group: Network Communication

    Parameter Name Default Memory Used Config Value Run Value
    ------------------------------ ----------- ----------- ------------ -----------
    additional network memory 0 0 0 0
    allow remote access 1 0 1 1
    allow sendmsg 0 0 0 0
    default network packet size 512 #1546 2048 2048
    max network packet size 512 0 2048 2048
    max number network listeners 5 342 5 5
    number of remote connections 20 123 20 20
    number of remote logins 20 82 20 20
    number of remote sites 10 678 10 10
    remote server pre-read packets 3 #122 3 3
    syb_sendmsg port number 0 0 0 0
    tcp no delay 0 0 1 1

    (1 row affected)
    (return status = 0)
    Execution Time (ms.): 0 Clock Time (ms.): 0

  5. #5
    Join Date
    May 2003
    The problem is most likely because you aren't using
    bind variables. I discovered that the java framework
    i was using wasn't using bind variables for jdbc calls.

    Don't pass in something like this:

    insert into a values ('x')

    , but instead use:

    insert into a values (?)

    and then bind the parameter with the value.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts