Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2002
    Posts
    2

    Unanswered: SQL1402N error on AIX

    Hi,

    I've installed DB2 7.2 on AIX4.3.3. but i'm unable to connect to the database using the following command

    connect to dbbame user db2inst1 using ibmdb2

    the error shown is

    SQL1402N cannot authenticate the user due to an unexpected system error.

    the db is a local db.

    i'm able to connect using the followin cmd successfully.

    connect to dbbame

    what authorisation should be provided to db2inst1??

    Regards
    Reeth

  2. #2
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: SQL1402N error on AIX

    Check with your system administrator first ... The very common cause of the problem is your user-id being disabled at the OS level.

    Cheers

    Sathyaram

    Originally posted by reet
    Hi,

    I've installed DB2 7.2 on AIX4.3.3. but i'm unable to connect to the database using the following command

    connect to dbbame user db2inst1 using ibmdb2

    the error shown is

    SQL1402N cannot authenticate the user due to an unexpected system error.

    the db is a local db.

    i'm able to connect using the followin cmd successfully.

    connect to dbbame

    what authorisation should be provided to db2inst1??

    Regards
    Reeth

  3. #3
    Join Date
    Sep 2002
    Posts
    2
    Hi,
    I've tried assigning all the group sets of root user to db2inst1 using smit, but to no avail. how do i make sure that my userid is not disabled at the OS level.
    Regards
    Reeth

  4. #4
    Join Date
    Oct 2002
    Posts
    1
    When I saw that message I had to make sure the the instance name I was using had remote login capabilities. As root use smit user and make sure remote logins are turned on. This is also where you would check to make sure the ID isn't locked out. Don't know if this will help at all, but you can try it.

    Another option is make sure that there is a loopback db alias

    A..Set up TCPIP as the DB/2 communication vehicle
    # su - <instance name>
    # db2set DB2COMM=tcpip

    B..Set up the bogus client
    Add the following lines to /etc/services:

    As root (There are tabs in between the three elements):
    db2service 3700/tcp # DB2service UDB/6000 DB2 servies
    db2servicei 3701/tcp # Reserved for Interrupt

    As DB2 instance:
    db2 catalog tcpip node <some_node_reference> remote 127.0.0.1 server db2service
    db2 catalog database <db_name> as <db_alias_name> at node <same_noderef_as_above> authentication server
    db2 update database manager configuration using SVCENAME db2service

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •