Results 1 to 2 of 2

Thread: missing table

  1. #1
    Join Date
    Oct 2002
    Location
    New Orleans
    Posts
    1

    Unhappy Unanswered: missing table

    I have an access Database with a table that contains demographics for physicians. One day, I tried to open the table and I got an error message that says "Record is deleted". When I clear that message, I get another one that says something like "Table cannot be viewed in datasheet mode". I can open it in design view but that's not much help. The doctor name field is also a control for a combo box on a form and the names still show up there but I need the table back for reference. Any ideas on how I can repair this other than making a whole new table?

  2. #2
    Join Date
    Oct 2002
    Location
    UK
    Posts
    21
    Have you tried 'Compact and Repair Database' on the Tools, Database Utilites menu?

    If that has no effect try this:
    1. Create a new database (make sure the existing one is closed)
    2. Choose File, Get External Data, Import from the menubar
    3. Browse for your existing database
    4. Select the table causing the problem and click OK

    The table will (hopefully) be imported into the new database and you can open it. If it's transferred correctly, either import the remainder of the old database and use the new one from then on, or delete the table from the old database and import it back in from the new one.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •