Results 1 to 7 of 7

Thread: error -25588

  1. #1
    Join Date
    Sep 2002
    Posts
    11

    Unanswered: error -25588

    I am facing a peculiar problem. I have Informix IDS installed on Sun. I am able to connect to the databse using dbaccess but when I try to connect from embedded sql code (.ec) I get sqlca error -25588 (appl. can not connect to database). I am sure that in both the cases I am trying to connect to the same database.
    Any clues?

  2. #2
    Join Date
    Oct 2002
    Posts
    52

    Re: error -25588

    Originally posted by sgupta001
    I am facing a peculiar problem. I have Informix IDS installed on Sun. I am able to connect to the databse using dbaccess but when I try to connect from embedded sql code (.ec) I get sqlca error -25588 (appl. can not connect to database). I am sure that in both the cases I am trying to connect to the same database.
    Any clues?
    I am using windows 2000 but -

    Are you connected with the same user/password ?

    look in your onconfig file - check the NETTYPE configuration

    check your sqlhosts

    and check that your network is working properly

    Hope I helped

    I get this error on windows when ever the net have problems, it kills my application, and I don't know how to eliminate it!


    Dafna

  3. #3
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    Do you connect using tcp or shm?
    can you give the output of the sqlhosts file and your CONNECT statement?
    It is possible you are encountering network problem, in case you are connecting with tcp. Check that you allocated enough poll-threads.
    In case of shm, check that your shm connection is not down. Set your INFORMIXSERVER to the corresponding value in the sqlhosts file and check with dbaccess.
    rws

  4. #4
    Join Date
    Sep 2002
    Posts
    11
    I was connecting using shm. Is there any shm configuration that needs to be done?

    my sqlhosts file looks like

    jumbo onipcshm c61 sqlexec1
    jumbo_net ontlitcp c61 sqlexec2

    onconfig
    ......
    SERVERNUM 1
    DBSERVERNAME jumbo
    DBSERVERALIASES jumbo_net
    DEADLOCK_TIMEOUT 60
    RESIDENT 0
    ....

  5. #5
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    shm doesn't need a port number, normally we just specify the servername again. Did you try localhost, or 127.0.0.1, instead of your machine name? (check yr /etc/hosts file)

    jumbo onipcshm localhost jumbo

    How many CPU's are in the machine?
    What is your NETTYPE config for onipcshm? Does it run on the CPUVP?
    rws

  6. #6
    Join Date
    Sep 2002
    Posts
    11
    You are right!. There is problem with the /etc/hosts file. Thanks for your help. Just curious, how is number of CPU related with this problem?

  7. #7
    Join Date
    Feb 2002
    Posts
    2,232
    I think Roelwe is referencing that you should have the most active nettype use the cpuvp - not the net vp class. So if shared memory is the dominant method for your applications accessing informix, it should be set to cpu. If your most dominant method is tcp, then that nettype should be set to cpu. The number of processors on your server will determine the NUMCPUVPS parameter in your onconfig file. This also is helpful in determining how many poll threads you can allocate in your nettype parameter that will actually use the cpu vp(s). If you allocate more poll threads than available cpu vp(s) in your nettype parameter -informix will use the net vp class for ALL poll threads - which defeats the purpose of assigning the cpu vp class to the nettype parameter.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •