Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2002
    Posts
    2

    Question Unanswered: Acc97 focus jumps to first record in datasheet view

    My Access97 app (Log) doesn't store data, that is done in linked tables in LogData. This is used by multi user on a LAN.

    I use a main form with two subforms. One of the subforms (Time) is in a datasheet view and contains Starttime and Endtime fields.

    After use of Log, 1 day to a month+, the Time subform starts messing up. Whenever someone clicks a field other then the very first starttime field, the focus jumps back to the first starttime field. If you click on the field you want and quickly press a key, the key stroke will show up in the field you clicked and the focus stays there and you can edit/enter data in the field.

    Anyone have any ideas about what's causing this and/or anything I could do to prevent it?

    Thanks

  2. #2
    Join Date
    Aug 2002
    Location
    Singapore
    Posts
    91

    Re: Acc97 focus jumps to first record in datasheet view

    Requerying or refreshing the subform also can cause the focus to move to the first. However, it is quite strange if this problem only appear recently. Is the problem only appear at the first time the subform get focus?

  3. #3
    Join Date
    Oct 2002
    Posts
    2
    No, it will work correctly on all records for weeks, then it starts jumping. Once it starts, it will jump on all records, all the time, for all users. At that point, I replace the application database with a backup copy, and everything will work correctly again, at least for a while.

  4. #4
    Join Date
    Jul 2001
    Location
    Estonia
    Posts
    33
    I have a very faint idea of what you are doing, but i think it is a good idea to check by which fileld your data is sorted.
    IMHO that sort of behaviour can only occur if sortig is screwed up.


    Originally posted by jboldig
    No, it will work correctly on all records for weeks, then it starts jumping. Once it starts, it will jump on all records, all the time, for all users. At that point, I replace the application database with a backup copy, and everything will work correctly again, at least for a while.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •