Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2002
    Posts
    3

    Unhappy Unanswered: Informix Not coming up ....

    Hi !!!

    Today morning our SYSADMIN rebooted SUN box, it came up fine but Informix is down.
    I am getting a message in Informix online.log as follows:
    "mt_shm_remove: WARNING: may not have removed all/correct segments".

    I checked /dev/rdsk/dbs* permissions, owner & group. Everything looks fine, it has 660 & Informix as owner & group. Checked the /etc/system parameters & that also looks fine. Checked SQLhosts & looks fine.

    Checked for ipcs, nothing is running except for 2 root process.

    I ran out of all my options, I am badly in need of some help, please folks help me out.

    Thanks
    Shashi

  2. #2
    Join Date
    Mar 2002
    Posts
    112

    re

    run oninit -vy and capture output text for more information then post it again

  3. #3
    Join Date
    Oct 2002
    Posts
    6
    This problem comes from the shared memory part of informix server.
    I'm not too good at shared memory management in the SUN-box, but your sysadm should be able to help you when you know it's a memory problem. There is some parameters in the onconfig file, setting shared memory system.

    Look at buffers,shmbase, shmvirtsize, shmadd and shmtotal, to see if something changed. Changes in the onconfig-file is logged in your
    %INFORMIXDIR%/%SERVERNAME%.log - file.

    Hope this helps ( at least a bit )
    /Ralph

  4. #4
    Join Date
    Mar 2002
    Posts
    112

    re

    Informix goes down and can't start to online again in my experience
    the share memory is still allocate or network port I/O is still allocate from informix

  5. #5
    Join Date
    Oct 2002
    Posts
    6
    Check with onstat -m to see if you've got any messages that states any errors in the shared memory base address.
    /R

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •