Results 1 to 4 of 4
  1. #1
    Join Date
    Dec 2001
    Posts
    16

    Question Unanswered: raw partition problem

    Hi,

    I have installed sybaes 12.5 on AIX (used raw partition for all devices).
    After my testing I have droped all devices. Now the OS is giving some error for those raw partition. Please let me out What should I do now?

    Is raw partitions currpted because of droping devices??

    Is this is OS problem?

    Is it required to drop and recreate the raw partitions again??


    Help me out


    Thanks & Regards,

    Siva

  2. #2
    Join Date
    Aug 2002
    Location
    Madrid, Spain
    Posts
    97
    I've read in other newsgroups' threads
    that AIX needs the first few KB of the
    raw device for itself (the volume manager
    stores something there).

    So, disk init must ensure they aren't
    overwritten by skipping them using
    the clause "vstart". I don't remember
    the correct value, but John McVicker
    recommended a full extent (16 KB);
    it's more than stricktly necessary but
    improves the performance.

    Well, it's clear that my memory is not
    my best quality. I suggest searching
    in comp.databases.sybase and alike.

    Regards,
    Mariano Corral

  3. #3
    Join Date
    Feb 2002
    Location
    Willy is on vacation
    Posts
    1,208
    Hiya Siva,

    For AIX + LVM(only) when you disk init the vstart must be specified 2.

    This is documented in ASE manuals.

    The reason being, the first to blocks(0 and 1) and that if you use vstart as 1, it will overwrite the system block that is reserved for LVM.

    I'm pretty sure, Sybase by default skips the first 2 blocks by default(unless you sepcify vstart = 1).

    Cheers
    Willy
    Last edited by willy_and_the_ci; 11-05-02 at 20:33.

  4. #4
    Join Date
    Dec 2001
    Posts
    16

    Re: raw partition problem

    thnak u
    Originally posted by siva
    Hi,

    I have installed sybaes 12.5 on AIX (used raw partition for all devices).
    After my testing I have droped all devices. Now the OS is giving some error for those raw partition. Please let me out What should I do now?

    Is raw partitions currpted because of droping devices??

    Is this is OS problem?

    Is it required to drop and recreate the raw partitions again??


    Help me out


    Thanks & Regards,

    Siva

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •