Results 1 to 9 of 9

Thread: Ora-12545

  1. #1
    Join Date
    Oct 2002
    Posts
    78

    Unanswered: Ora-12545

    Hai

    How to connect to mts from client over network .When i try to connect to mts server from client over network ,its givings the below message

    ORA-12545 Connect failed because target host or object does not exist

    Our database version is 8.1.6
    Any one any idea it should be appreciated
    Regards
    mohan

  2. #2
    Join Date
    Mar 2002
    Location
    Ireland
    Posts
    181
    could you show me your tnsnames.ora and sqlnet.ora files?

  3. #3
    Join Date
    Oct 2002
    Posts
    78
    Hai
    Thanks for ur Reply
    i started the listerner before starting the database . I got connected to shared server process where database resides on machine ,but able to connecting from client over network a while time in net8 assistant , then I got the below message when try to test serice "test2" in net8
    on client
    ORA-12545:THE CONNECTION FAILED THE TARGET HOST OR OBJECT DOES NOT EXIST

    What is the above cause

    Second thing is when got connected to mts from client over the network
    it showing the "server=NONE status =INACTIVE " and server side where mts resides " server=shared status =ACTIVE"

    What is default connection_timeout value and where to specify the value


    At client side
    ===============
    SQL> select username,server,status from v$session;

    USERNAME SERVER STATUS
    ------------------------------ --------- --------
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    SYSTEM NONE INACTIVE

    USERNAME SERVER STATUS
    ------------------------------ --------- --------
    SYSTEM DEDICATED ACTIVE




    The server side where database resides
    =======================================
    SQL> select username,server,status from v$session;

    USERNAME SERVER STATUS
    ------------------------------ --------- --------
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    SYS SHARED ACTIVE

    11 rows selected.












    Any idea it should be appreciated
    Regards
    mohan

  4. #4
    Join Date
    Mar 2002
    Location
    Ireland
    Posts
    181
    1) Can you ping the server from the client?
    2) Is your tnsnames correct?

  5. #5
    Join Date
    Apr 2002
    Location
    California, USA
    Posts
    482

    Cool

    The CONNECT_TIMEOUT is in listener.ora file. If you don't have it there, then is the default value in place.

    There could be a resource issue on your OS. Try increasing this parameter to 15 and see what happends. Once the parameter is changed, stop and restart the listener.


    Hope that helps,

    clio_usa
    OCP - DBA

  6. #6
    Join Date
    Oct 2002
    Posts
    78

    ORA-12545

    Originally posted by Breen
    1) Can you ping the server from the client?
    2) Is your tnsnames correct?
    HAI
    I could able to ping from server to client,and once strart the listener before the database starting up it could connect to mts server.When session is established from client performing all operations like query the objects.When session is close and open another session i could not connect to database getting the below error
    ORA-12545:THE CONNECTION FAILED THE TARGET HOST OR OBJECT DOES NOT EXIST

    I could not understand what is the cause.Please explain what is the cause could it bee?
    Regards
    mohan

  7. #7
    Join Date
    Mar 2002
    Location
    Ireland
    Posts
    181
    Hi Mohan,
    If I am getting this correct.
    You connected from client to server no problem.
    Logged off and attempted to connect from the same client again but could not.
    If yes could you publish your initsid.ora settings

  8. #8
    Join Date
    Apr 2002
    Location
    California, USA
    Posts
    482

    Smile

    Seems to me that after the initial connection the dispatchers are redirecting the traffic to another IP address. You can force them to use the IP address on your server. Add this line in your init.ora file:

    DISPATCHERS = "(ADDRESS = (PROTOCOL = TCP)(HOST =server_ip_address))(DISPATCHERS = number_of_dispatchers_you_like)"

    You can also in the DB server c:\winnt\system32\drivers\etc\hosts file an entry:

    db_server_ip_address db_server_hostname alias


    Hope that helps,

    clio_usa
    OCP - DBA

  9. #9
    Join Date
    Oct 2002
    Posts
    78

    ORA-12545

    Hai
    As for u say ,i modified init.ora file as follows

    init.ora
    ========:
    MTS_DISPATCHERS="(PROTOCOL=tcp)(LISTENER=(ADDRESS_ LIST=(ADDRESS=(PROTOCOL=TCP)(PORT=1528)(HOST=10.0. 0.79))))"

    MTS_MAX_DISPATCHERS =16
    MTS_SERVERS =2
    MTS_MAX_SERVERS =10



    When connecting from client to mts server not establishing shared connection its giving the below message

    ORA-12545:THE CONNECTION FAILED THE TARGET HOST OR OBJECT DOES NOT EXIST

    It was stranging because two days back it connected to server
    a while time from client and given the above error message when first start listener before database
    to start up.Then onwards i am unable to connect to mts server from client ,whenever connecting from client got the above message ,but i am able to connect to dedicated server from client
    without any difficulty.I am not getting error message at server where mts server reside on the machine when connecting to mts from sqlplus application or net 8 componenet.
    I had the below quey ,it seems to be believed my database running with mts.


    At server
    =========
    SQL> select username,server,status from v$session;

    USERNAME SERVER STATUS
    ------------------------------ --------- --------
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    DEDICATED ACTIVE
    SYS SHARED ACTIVE

    11 rows selected.


    I am giving listener.ora,sqlnet.ora,tnsnames.ora file below:
    ================================================== ========

    Listener.ora file
    =================
    # LISTENER.ORA Network Configuration File: C:\Oracle\Ora81\network\admin\listener.ora
    # Generated by Oracle configuration tools.

    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC0))
    )
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = tejaswini)(PORT = 1521))
    )
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = tejaswini)(PORT = 1528))
    )
    )

    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = PLSExtProc)
    (ORACLE_HOME = C:\Oracle\Ora81)
    (PROGRAM = extproc)
    )
    (SID_DESC =
    (GLOBAL_DBNAME = test1)
    (ORACLE_HOME = C:\Oracle\Ora81)
    (SID_NAME = test1)
    )
    (SID_DESC =
    (GLOBAL_DBNAME = test2)
    (ORACLE_HOME = C:\Oracle\Ora81)
    (SID_NAME = test2)
    )
    )



    Sqlnet.ora
    ============:
    # SQLNET.ORA Network Configuration File: C:\Oracle\Ora81\network\admin\sqlnet.ora
    # Generated by Oracle configuration tools.

    NAMES.DEFAULT_DOMAIN = nirbeeja3.com

    SQLNET.AUTHENTICATION_SERVICES= (NTS)

    NAMES.DIRECTORY_PATH= (TNSNAMES, ONAMES, HOSTNAME)





    Tnsnames.ora
    ============
    # TNSNAMES.ORA Network Configuration File: C:\Oracle\Ora81\NETWORK\ADMIN\tnsnames.ora
    # Generated by Oracle configuration tools.

    TEST2.NIRBEEJA3.COM =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = tejaswini)(PORT = 1528))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = test2)
    (SRVR = shared)
    )
    )

    TEST1.NIRBEEJA3.COM =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = tejaswini)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = test1)

    )
    )



    Please let me know where i made mistake.I was stuck with this problem for last one week from connecting from client to server

    Regards
    mohan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •