Results 1 to 6 of 6
  1. #1
    Join Date
    Aug 2002
    Location
    india
    Posts
    41

    Unanswered: transaction log file size is increasing rapidly

    The mdf file size is 6.5 gb & transaction log file size 7.7 gb & its getting increased day by day. I have observed there is no such long running query been implemented recently.There is also no replicated transaction in transactions log to be transferred to distribution database.
    can u pl tell me the remedy for comming out of this problem.
    I have taken the full datbase backup as well as transaction log but it does not reflect on the database transaction log file size.


    prompt reply will be highly appriciated.

  2. #2
    Join Date
    Oct 2002
    Posts
    29

    Re: transaction log file size is increasing rapidly

    Check database - properties - options. Make sure that 'Auto shrink' option is checked (ticked). If not, check it. To truncate the log manually, use 'All tasks - shrink database' option. You may choose to shrink both the data and the log file or just the log file.
    Regards, Ravi.

  3. #3
    Join Date
    Sep 2002
    Posts
    53

    Re: transaction log file size is increasing rapidly

    I just posted a remedy to this problem. The post is "shrinking log file" and can be found on the first or second page here.

    HTH!
    KDK

  4. #4
    Join Date
    Aug 2002
    Location
    india
    Posts
    41

    Re: transaction log file size is increasing rapidly

    Originally posted by ranjan
    The mdf file size is 6.5 gb & transaction log file size 7.7 gb & its getting increased day by day. I have observed there is no such long running query been implemented recently.There is also no replicated transaction in transactions log to be transferred to distribution database.
    can u pl tell me the remedy for comming out of this problem.
    I have taken the full datbase backup as well as transaction log but it does not reflect on the database transaction log file size.


    prompt reply will be highly appriciated.
    contn of quesition

    I have tried with all the possible alternatives like

    selected the auto shrink option->manually done shrlinking ->through qa also i have given dbcc shrink file option but still facing the same problem

  5. #5
    Join Date
    Sep 2002
    Location
    Dallas
    Posts
    7
    If you do full DB back-ups, and not transaction log dumps, make sure the recovery model for the database (under options) is set to "simple", otherwise "checkpointed" transactions won't be removed. If the recovery model is "full" the trans. log will continue to grow larger until you dump it. If you are using SQL7, i think the terminology is different for the recovery models. Also once/if you change the recovery model, you should do a "dump tran DBName with no_log" to free the space, then do a shrink on the log file.

    If none of that works, make sure you don't have any open/uncommited transactions running. You can't dump active transactions.

  6. #6
    Join Date
    Feb 2002
    Posts
    2,232
    Check out the following posts:

    post1

    post2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •