Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2002
    Posts
    8

    Question Unanswered: ASP and Oracle OleDB Provider Problem

    I'm a running web server running:
    W2K/SP3 with IIS5
    MDAC 2.7

    I also installed on the web server the following Oracle components:
    Oracle 9i Client 9.2.0.1.0
    Oracle Provider OLE DB 9.2.0.2.0
    Oracle Objects for OLE 9.2.0.4.5

    However, I am getting error below:
    ADODB.Connection error '800a0e7a'
    Provider cannot be found. It may not be properly installed.
    /scripts/sec.asp, line 21

    Have given anonymous web user account on the server read/execute permissions to the following directories and subdirectories:

    C:\Program Files\Common Files
    C:\Program Files\Oracle
    D:\Oracle\Ora92

    Here's where I try to make the connection in my code:
    Set OraConn = Server.CreateObject("ADODB.Connection")

    Oraconn.ConnectionString = "Provider=OraOLEDB.Oracle;Data Source=oraDB;User ID=user1;Password=password;"

    OraConn.Open

    oraCommandStr = "SELECT GUID FROM SECURITY_TABLE WHERE GUID = 'user2'"

    Set objRS = Server.CreateObject("ADODB.Recordset")
    Set objRS = OraConn.Execute(OraCommandStr)

    Response.Write objRS.Fields("GUID")

    Does anyone know what I may be doing wrong or have not checked?

    thanks
    simpson

  2. #2
    Join Date
    Jun 2002
    Posts
    18
    Can you connect using the msdaora provider

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •