Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2002
    Posts
    1

    Unanswered: DB2 server error code: "146","*", "*". SQLSTATE=08001

    I'm using UDB7.2 on Solaris 7 and am having problems connecting my instance to the server. I have the sample database created on the server (Solaris) and am trying to connect my client instance (Solaris) to it. I get the following TCPIP error:

    SQL30081N A communication error has been detected. Communication protocol being used: "TCP/IP". Communication API being used: "SOCKETS". Location where the error was detected: "". Communication function detecting the error: "connect". Protocol specific error code(s): "146", "*", "*". SQLSTATE=08001.

    I looked through the DB2 documentation, but to little avail... they mentioned error return codes 1, 2, 9, 10, 20, 27, 79 and 10032 in the Connectivity Supplement document, but nothing about return code 146. Doing searches on various sites has turned up nothing.

    1) My DB2COMM is set to TCPIP.
    2) The service names and port numbers match between server and client.
    3) I installed DB2 on both the server and client using the pkgadd command on all the packages.

    Anyone ever encountered this?

    Thanks.

  2. #2
    Join Date
    Sep 2002
    Posts
    456

    Re: DB2 server error code: "146","*", "*". SQLSTATE=08001

    Make sure you can manually ping the server from your client, then try conecting again!!!


    Paul Pabla

    Originally posted by vtgrimace
    I'm using UDB7.2 on Solaris 7 and am having problems connecting my instance to the server. I have the sample database created on the server (Solaris) and am trying to connect my client instance (Solaris) to it. I get the following TCPIP error:

    SQL30081N A communication error has been detected. Communication protocol being used: "TCP/IP". Communication API being used: "SOCKETS". Location where the error was detected: "". Communication function detecting the error: "connect". Protocol specific error code(s): "146", "*", "*". SQLSTATE=08001.

    I looked through the DB2 documentation, but to little avail... they mentioned error return codes 1, 2, 9, 10, 20, 27, 79 and 10032 in the Connectivity Supplement document, but nothing about return code 146. Doing searches on various sites has turned up nothing.

    1) My DB2COMM is set to TCPIP.
    2) The service names and port numbers match between server and client.
    3) I installed DB2 on both the server and client using the pkgadd command on all the packages.

    Anyone ever encountered this?

    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •