Results 1 to 9 of 9
  1. #1
    Join Date
    Nov 2002
    Posts
    6

    Unanswered: onbar - configuration problem on Win2k

    hi,

    I am using Informix 2000 on win2k, just tried to play a bit with the database but ... the logical logs get full pretty quick - how to empty them?
    I've found information about onbar -l but it does not work in my case?
    I get the following message:

    ------------
    WARNING: Cannot access configuration file $INFORMIXDIR/etc/$ONCONFIG.
    Unable to read parameters from $INFORMIXDIR/etc/$ONCONFIG (UNIX) or
    %INFORMIXDIR%\etc\%ONCONFIG% (NT).
    ------------

    Where to set up the path correctly?
    I have no idea, I search all files and ther is nothing ...

    thanks in advance for help

    ad

  2. #2
    Join Date
    Oct 2002
    Posts
    52

    Smile

    Hi

    If you just playing - what you need to do is change the logs backup to nul:
    LTAPEDEV nul # Log tape device path
    then turn the service off and on (control pannel services)

    If you want a quick backup try ontape (then the ltapedev should point to a file and so is the tapedev).

    The onbar is a bit more complicated and if you don't realy interested in the backup, keep away from it.

    Dafna

  3. #3
    Join Date
    Nov 2002
    Posts
    6

    thank you :-)

    Originally posted by thedafna
    If you just playing - what you need to do is change the logs backup to nul:
    LTAPEDEV nul # Log tape device path
    then turn the service off and on (control pannel services)
    Dafna
    thanks, works fine now

    but it is a pain to find any help for configuring the sever,
    now i get another error,

    271: Could not insert new row into the table.
    131: ISAM error: no free di
    847: Error in load file line 280.

    so i have to find what is going on,
    there is over 2 GB of free space on the disk, i try to import around 32 MB of data into the database ....

    do you know where to look for any good help about administration of Informix?

  4. #4
    Join Date
    Oct 2002
    Posts
    52
    A guess - your database is on the rootdbs
    try on the command line onstat -d
    you'll see the size and the free

    Dafna

  5. #5
    Join Date
    Nov 2002
    Posts
    6

    ok, moving forward ...

    Originally posted by thedafna
    A guess - your database is on the rootdbs
    try on the command line onstat -d
    you'll see the size and the free

    Dafna
    done :-)
    I just added a new chunk and it is fine

    I tried ISA and it worked fine this time.
    I have the database on separate space, not rootdbs.

    it seems all is ok, so I can move to my main subject, create a SQL Query Builder for Informix 2000 (separate module to be used by others)

    - next painful experience in front of me - connecting to the database server from separate machine, I have 16bit (sic!) ODBC driver that I have to use (client requirements)

    Does anybody has any experience with such task?

    PS: Dafna, I own you a beer, let me knwo when you visit Krakow (Poland) :-)
    you are welcome
    thanks again

  6. #6
    Join Date
    Oct 2002
    Posts
    52
    I have an odbc Data sources for my databases in order to let external application (Crystal Report) connect to it, So what is your problem?

    Dafna

  7. #7
    Join Date
    Nov 2002
    Posts
    6

    CSDK

    Originally posted by thedafna
    I have an odbc Data sources for my databases in order to let external application (Crystal Report) connect to it, So what is your problem?

    Dafna
    at the moment I have some problems with connecting to the server through ODBC, I think there is a problem with configuration of locale...

    I am also looking for CSDK for Win32 platform (WinXP would be the best)

    I have Informix 3.32 ODBC driver.

  8. #8
    Join Date
    Oct 2002
    Posts
    52
    Did you install Informix client on the other PC?

  9. #9
    Join Date
    Nov 2002
    Posts
    6
    Originally posted by thedafna
    Did you install Informix client on the other PC?
    yes,

    actually my configuration:

    win2k prof with informix dynamic server 9.21 running on vmware workstation

    win xp as a host system with Informix Connect ODBC driver

    I had to put extra entry into my services file on client system, now all works fine, so I really moved forward with the project.

    regards
    ad

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •