Results 1 to 3 of 3
  1. #1
    Join Date
    Sep 2002
    Location
    Pakistan
    Posts
    17

    Arrow Unanswered: Some problem with IBM-Informix IDS 7.31.UC5

    Our environment is as follows:

    IBM Informix IDS Version 7.31.UC5



    Unix Operating System = SCO_SV
    Release = 3.2v5.0.6


    We had a problem while using IDS 7.31.UC5 that suddenly it stopped connecting to Database Engine using Shared memory connection. However, the network connections were made successfully. It was giving error -25588.

    We were having different instances running at the same time. They are running well for long time but suddenly it gave this error.
    I restarted one of instances after making it down using "onmode -sky" and then "oninit", still it was giving the same error.
    It was also giving the error even using dbaccess.
    We have two type of connections one for Shared memory and other for TCP in sqlhosts file using "olipcshm" and "oltlitcp".
    If I try to connect using the dbaccess Connect option and use the network database server, it was making the connection well.

    Later I restarted the Unix machine and after reboot every thing goes fine.

    This is a production machine and is being used heavily on 24 hours a day and 7 days a week. So such condition is very uneasy for our users.

    Please advise that when this error normally occurs and how to identify and resolve it and in the end how we can avoid this error.

    Hope to listen from you soon.

    Thanks in advance
    Last edited by iahmad; 11-25-02 at 12:01.
    Istikhar Ahmad
    ------------------
    Tel: (92-42) 111000911
    iahmad@i2cinc.com
    http://www.i2cinc.com

  2. #2
    Join Date
    Nov 2002
    Posts
    10

    Re: Some problem with IBM-Informix IDS 7.31.UC5

    Check couple things before you go any further.

    1. The system message file to see is there any not enough shared memory allocation... This is always happening.
    2. Conflict setting in the host and the services.
    3. make sure you have the following shared memory setting:
    forceload:sys/semsys
    forceload:sys/shmsys
    set shmsys:shminfo_shmmax=4294967295
    set shmsys:shminfo_shmmin=1
    set shmsys:shminfo_shmmni=100
    set shmsys:shminfo_shmseg=100
    set semsys:seminfo_semaem=16384
    set semsys:seminfo_semmap=64
    set semsys:seminfo_semmni=4096
    set semsys:seminfo_semmns=4096
    set semsys:seminfo_semmnu=4096
    set semsys:seminfo_semmsl=110
    set semsys:seminfo_semopm=100
    set semsys:seminfo_semume=64
    set semsys:seminfo_semusz=96
    set semsys:seminfo_semvmx=32767

    Good Luck

  3. #3
    Join Date
    Nov 2002
    Location
    Portugal
    Posts
    2

    Re: Some problem with IBM-Informix IDS 7.31.UC5

    Hi!

    Check the Kernel parameters recomendations at the $INFORMIXDIR/release/en_us/0333/IDS_7.3 file

    You also may need to tune the NETTYPE parameter in your ONCONFIG file (look at the Informix manuals).

    NOTE:
    =====
    In SCO OpenServer 5.0.x there is no "/etc/system" file to tune the kernel ...

    You must tune the kernel parameters with /etc/conf/bin/idtune (man ADM idtune), build the new kernel with /etc/conf/cf.d/link_unix (man ADM link_unix) and the reboot to activate the new kernel. For example:

    (on the console, login as root an go to single-user mode ...)

    cd /etc/conf/cf.d

    ../bin/idtune SHMMIN 1
    ../bin/idtune SHMSEG 6
    ../bin/idtune SEMMNI -2048 -MAX 8192
    ...
    ...
    ...

    ./link_unix -y

    shutdown -y -g0 -i6




    Hope this helps.

    Vitorino


    Originally posted by tn5353
    Check couple things before you go any further.

    1. The system message file to see is there any not enough shared memory allocation... This is always happening.
    2. Conflict setting in the host and the services.
    3. make sure you have the following shared memory setting:
    forceload:sys/semsys
    forceload:sys/shmsys
    set shmsys:shminfo_shmmax=4294967295
    set shmsys:shminfo_shmmin=1
    set shmsys:shminfo_shmmni=100
    set shmsys:shminfo_shmseg=100
    set semsys:seminfo_semaem=16384
    set semsys:seminfo_semmap=64
    set semsys:seminfo_semmni=4096
    set semsys:seminfo_semmns=4096
    set semsys:seminfo_semmnu=4096
    set semsys:seminfo_semmsl=110
    set semsys:seminfo_semopm=100
    set semsys:seminfo_semume=64
    set semsys:seminfo_semusz=96
    set semsys:seminfo_semvmx=32767

    Good Luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •