Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2002
    Posts
    87

    Unanswered: Problems with ~large~ table

    Hello everyone,
    I have a little problem with a Table im using to store notes on articles:
    Design:
    id - int - identity (auto)
    Title - varchar(50)

    currently the table is containing ~12000 datasets (not much if you ask me).

    Problem:
    If I try to edit/add recordsets, I get a timeout.
    In Access:
    'ODBC Error adding recordset'

    In SQL
    - None - Timeout (I Quit after 2.5 minutes of INSERT query)

    does anybody know a solution to this problem?

    Thanks for helpin'!

  2. #2
    Join Date
    Jul 2002
    Posts
    87
    In Addition to the upper text:

    Strangely it works sometimes - I know that this should be that slow, the textfield is indexed - w/o duplicates - but i have used the same structure for other tables (with over 5 times as much data) and there it works..

    Is it possible that indexing w/o duplicates causes this problems?

  3. #3
    Join Date
    Jul 2002
    Posts
    229
    Have you tried inserting via Enterprise Mgr to see if you get the same error?

    Have you seen what's happening through, for instance, SQL Profiler?

  4. #4
    Join Date
    Jul 2002
    Posts
    87
    I've tried trough Access, Acced direct table edit, SQL Query Analyzer - all have the same problem (except that QA doesn't have a set timeout)...

  5. #5
    Join Date
    Feb 2002
    Posts
    2,232
    Which type of index are you using ? In your previous instances where you had no problems, did you have the index using the "without duplicates" option ?

  6. #6
    Join Date
    Jul 2002
    Posts
    87
    Originally posted by rnealejr
    Which type of index are you using ? In your previous instances where you had no problems, did you have the index using the "without duplicates" option ?
    In the troubled table i'm using index: w/o duplicates - in the not troubled table the row is indexed but with duplicates...
    another problem is - I currently cannot change this, because I dont have enough space for the transaction log to save 15000-50000 rows (indexes)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •