Results 1 to 4 of 4
  1. #1
    Join Date
    Dec 2002
    Posts
    5

    Unhappy Unanswered: Importing text file using Schema.ini

    I imagine there is probably something simple that I'm missing, but I can't for the life of me get this to work.

    I'm trying to import a text file "EXT_MEMBERS.TXT" into my Access 2000 database. I'm using a schema.ini and the doCmd.TransferText action.

    Every time I try to run the code I get;

    "The text file specification 'schema.ini' does not exist. You cannot import, export, or link using this specification"

    Here is how my doCmd code looks;

    DoCmd.TransferText , "schema.ini", "Members_Extract", "C:\Data Extracts\EXT_MEMBERS.TXT"

    Now I have the schema.ini file in the same directory as the EXT_MEMBERS.TXT, just like the help files said to, but still no luck.

    Thanks in advance to anyone who can save my sanity!

  2. #2
    Join Date
    Nov 2002
    Location
    Hillsboro, OR, USA
    Posts
    59
    Try deleting the Schema.ini file (or moving it somewhere else rather) and running the TransferText command without the second parameter, like so:

    DoCmd.TransferText , , "Members_Extract", "C:\Data Extracts\EXT_MEMBERS.TXT"

    What happens?

    Brian

  3. #3
    Join Date
    Dec 2002
    Posts
    5
    I tried moving the file from the folder. Now all I have in the folder is the txt file I'm trying to import. I get the exact same error. Right down to the word.

    If it possible I may be missing references? I just don't know I'm going cross-eyed trying to figure it out!

  4. #4
    Join Date
    Dec 2002
    Posts
    5
    Oops I goofed when I replyed last time. I remove the schema.ini file but never removed the reference to the file in the doCmd.

    I ran the exact command you had there and now I get this error;

    Field 'F1' doesn't exist in destination table 'Members_Extract'

    Tyler

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •