Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2002

    Red face Unanswered: oracle odbc driver's problem

    I run an application to call stored procedure via oracle ODBC driver.
    Environment are as follows:
    Oracle DB Ver:
    Client Tool Ver:
    ODBC Ver:3.520.7926.0
    oracle ODBC driver ver:

    The stored procedure is versy simple, it just insert a piece of data into the table.The table has just a field of varchar2 type. I found that when the string to be inserted include character '\' like '\1234567890', the application will fail , the error info is just like this:
    State:37000,Native:0,Origin:[Oracle][ODBC]Syntax error or access violation
    I created a table in SQL Server and repeat the same thing, the app runs well. And i executed the stored procedure manually in SQL*Plus, and it works fine too. It seems that there exist the problem in oracle odbc driver. Does anybody has the same experience? How can i avoid it? I mean if the string include character '\', how can i insert the string into table sucessfully via odbc?

  2. #2
    Join Date
    Dec 2002


    I solved problme by meself.
    Just update ODBC driver to the latest version, and the application works fine now. I've met many strange problems when using oracle, and 90% of the problems can be solved by installing the newest patchs or update drivers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts