Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2002
    Posts
    2

    Unanswered: Unable to start SQLServerAgent

    I am having trouble starting SQL Server Agent on my SQL 2000 server. The OS is Win 2000 (sp3).

    When I try to start from Entrprise manager, nothing happens. If I try to start the service from windows service manager I get:

    Could not start the SQLSERVERAGENT service on Local
    Computer. The service did not return an error. This could
    be an internal Windows error or an internal service error.
    If the problem persists, contact your system administrator.

    Then if I look at the SQL Server Agent error log in SQL EM I get two errors:

    [298] SQLServer Error: 170, Line 47: Incorrect syntax near 'COLLATE'. [SQLSTATE 42000] (ConnIsLoginSysAdmin)

    and

    [000] SQLServerAgent must be able to connect to SQLServer as SysAdmin, but '(Unknown)' is not a member of the SysAdmin role

    I have checked that the login I'm using for the service has SysAdmin access to SQL Server.

    Any ideas?

    Thanks,
    Gary

  2. #2
    Join Date
    Dec 2002
    Posts
    2

    Re: Unable to start SQLServerAgent, Solved

    I just figured it out. I had imported databases from SQL 7 and I had to update the compatability level. I used
    EXEC sp_dbcmptlevel <your_DB_name>, 80


    Originally posted by gary.abramson
    I am having trouble starting SQL Server Agent on my SQL 2000 server. The OS is Win 2000 (sp3).

    When I try to start from Entrprise manager, nothing happens. If I try to start the service from windows service manager I get:

    Could not start the SQLSERVERAGENT service on Local
    Computer. The service did not return an error. This could
    be an internal Windows error or an internal service error.
    If the problem persists, contact your system administrator.

    Then if I look at the SQL Server Agent error log in SQL EM I get two errors:

    [298] SQLServer Error: 170, Line 47: Incorrect syntax near 'COLLATE'. [SQLSTATE 42000] (ConnIsLoginSysAdmin)

    and

    [000] SQLServerAgent must be able to connect to SQLServer as SysAdmin, but '(Unknown)' is not a member of the SysAdmin role

    I have checked that the login I'm using for the service has SysAdmin access to SQL Server.

    Any ideas?

    Thanks,
    Gary

  3. #3
    Join Date
    Jan 2005
    Posts
    1

    Help - Please

    Hello.

    I have the same problem as you had.
    I may have run som DB upgrade from 7, but I don't have that DB now.

    Hos can I recover from this ??

    Do I have to run the upgrade from 7 again, and then the command ?

    Where do I run the command ??

    Please help me......

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •