Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2003
    Posts
    1

    Question Unanswered: Data Access Pages - confusion!

    Very confused, hope someone can help! Created simple mdb (company info type stuff), with ODBC link to SQL db, saved it as Data Access Page. Works fine, allows edits back to SQL db. Db will have tens of thousands of records eventually, so we wanted to incorporate a simple SEARCH function so the user can type in "micr" and get records that contain "micr" in their name. This is as simple as can be in regular access (add a button, choose search, done), but it's apparently not available now that the app is a Data Access Page (DAP).

    Tried to create a second mdb, this time with the search button incorporated before it was saved as a DAP. Saved it off as DAP, but now the records it displays cannot be edited and we get a "the command or action 'save record' isn't available now" error when we try to save.

    Created a third mdb, same thing, "the command or action 'save record' isn't available now". All the while the first one still saves changes back just fine. Tried all the standard troubleshooting steps (fields not locked, edit OK selected, other users, other apps open linked to the db, etc)...everything checked out OK, just can't get 2nd or 3rd mdb/DAP to save any changes.

    Wouldn't be a problem if we could just add a simple search button to the original, which still works fine.

    Please help! We need either a solution for the "the command or action 'save record' isn't available now" problem, or a way to incorporate a very simple search button in the original DAP.

    Thanks in advance!
    Gary

  2. #2
    Join Date
    Aug 2002
    Location
    Charlotte NC
    Posts
    665
    Just from reading it seems like the comand to find a record is applying a filter and aparently DAP apps dont like filters when you want to save.
    If it is applying a filter maybe you should see about removing the filter before you save, maybe make a save button that removes the filter then does the save command.....just a guess though
    Jim

  3. #3
    Join Date
    Oct 2002
    Location
    NSW Australia
    Posts
    61
    ADP's use ADO references not DAO. So when editing records you need to work directly with the recordset object. The Save method doesn't get used, instead look up HELP on the Update Method.

    If you need more help post your SQL for you recordset and we can do an example for you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •