Results 1 to 6 of 6
  1. #1
    Join Date
    Jan 2003
    Posts
    4

    Unanswered: Query Analyzer - Turn Off Messages

    I am forced to use a cursor to update hundreds of thousands of rows one at a time. This is because I need to scroll back and forth to fetch variables and make updates.

    All's well except for the number messages - (1 row(s) affected) - that it generates each time I update. The volume swamps my PC while the server chugs merrily along.

    How do I shut the messages off ?

  2. #2
    Join Date
    Oct 2002
    Posts
    369

    Re: Query Analyzer - Turn Off Messages

    Q1 All's well except for the number messages - (1 row(s) affected) - that it generates each time I update. The volume swamps my PC while the server chugs merrily along. How do I shut the messages off ?
    A1 -- You may use Set NoCount On. For example:

    Select 0 As 'Initial Test'
    Go

    Set NoCount On

    Select 1 As 'NoCount On Test'

    Set NoCount Off

    Select 2 As 'NoCount Off Test'

  3. #3
    Join Date
    Jan 2003
    Posts
    4
    Thank you.

    Sorry to say that when I ran the test and I still get the message.

    Screen print attached.

  4. #4
    Join Date
    Oct 2002
    Posts
    369
    -- Try just the following two statements:

    Set NoCount On

    Select 1 As 'NoCount On Test'

  5. #5
    Join Date
    Jan 2003
    Posts
    4
    Ignore that sorry it works fine

  6. #6
    Join Date
    Oct 2002
    Posts
    369
    No problem.

    The (Set NoCount Off) statement example was included to demonstrate how to re-enable count displays.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •