Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2003
    Posts
    2

    Post Unanswered: deinstall server

    What is the best way to remove an incorrectly named ASE 12.0 server from an AIX machine?

  2. #2
    Join Date
    Sep 2002
    Posts
    8
    0. find the devices "physical_name" useing by using "sp_helpdevice"
    then shutdown the server
    1. remove the server entery from interfaces file nornaly its at $SYBASE/interfaces

    2. remove the errorlog at $SYBASE/install

    3. remove the run file its $Sybase/install/RUN_<yourserverrname>
    4. remove old config files ir $SYBASE the name will be like <yourservername>.xxx
    5 remove devices allocated using the physical_name from step 0

  3. #3
    Join Date
    Feb 2002
    Location
    Willy is on vacation
    Posts
    1,208
    Hiya Wilson,

    You don't have to remove the Server to rename a Server. Check this out.

    I've a server called "ASE1200" and to rename it to "ASE1200NEW".

    AIXsh% isql -Usa -P -SASE1200
    1> select @@servername
    2> go

    ------------------------------
    ASE1200

    (1 row affected)
    1> sp_dropserver ASE1200
    2> go
    Server dropped.
    (return status = 0)
    1> sp_addserver ASE1200NEW,local, ASE1200NEW
    2> go
    Adding server 'ASE1200NEW', physical name 'ASE1200NEW'
    Server added.
    (return status = 0)
    1> shutdown
    2> go
    Server SHUTDOWN by request.
    AIXsh%

    vi RUN_ASE1200 and change the servername to ASE1200NEW

    AIXsh% more RUN_ASE1200
    #!/bin/sh
    #
    /space/ASE1200/ASE-12_0/bin/dataserver \
    -sASE1200NEW \
    -d/space/ASE1200/devices/master.dat \
    -e/space/ASE1200/ASE-12_0/install/ASE1200.log \
    -M/space/ASE1200 \

    Change the interfaces file entry
    ASE1200NEW
    master tli tcp /dev/tcp \x00022dc6381ae7660000000000000000
    query tli tcp /dev/tcp \x00022dc6381ae7660000000000000000


    Start the Server and voila you have a Server with new name.
    1> select @@servername
    2> go

    ------------------------------
    ASE1200NEW

    (1 row affected)

    Cheers
    Willy
    Last edited by willy_and_the_ci; 01-05-03 at 20:40.

  4. #4
    Join Date
    Dec 2003
    Posts
    14

    SP_DROPSERVERNAME

    When I do this isql -Usa -Ppassword -SSALES--OK I get in
    >
    but this
    > select @@servername
    2> go

    ------------------------------
    NULL
    (1 line affected)

    The servername is not NULL. If I run sybase central I see
    SALES
    SALES_BS
    SALES_XP

    but this
    > sp_dropserver SALES
    2> go

    FAILS,
    "server name does not exist.

    Any ideas?

  5. #5
    Join Date
    Nov 2002
    Location
    Switzerland
    Posts
    524
    It's a known and old bug : the local server is missconfigured.

    Code:
    exec sp_dropserver local
    exec sp_addserver YourServer, local, YourServer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •