Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2003
    Posts
    4

    Unanswered: Database not found ...

    Hi ...

    I got the following error:

    SQLException: Database not found or no system permission.

    My user and password are rigth. but I where type the database path? if the url is:
    "//website:1533/maq:INFORMIXSERVER=website;user=maquser;password=l alala;

    My database is /apm/bd

    hosts=website
    port=1533
    dbname=maq
    bdserver=website
    user=maquser
    pass=lalala

    When I change
    bdname=/apm/bd/maq

    then I got the following error:

    java.sql.SQLException: Server does not support GLS variables DB_LOCALE, CLIENT_LOCALE or GL_DATE.

    Regards

  2. #2
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    I assume you are working with Standard Engine. Do you have a version of the product?
    A few known issues for v5 and v7, but I think you are hitting this one:

    THE JDBC DRIVER IS UNABLE TO CONNECT TO STANDARD ENGINE UNLESS THE DATABASE RESIDES IN THE CONNECTING USER'S
    HOME DIRECTORY OR A SUBDIRECTORY.
    A possible workaround for this is to create a symbolic link in the users home directory to the database. Another workaround would be to pass DBPATH variable in your url. Set DBPATH to the location of the database.

    jdbc:informix-
    sqli://<hostname>:<port>/<database>:informixserver=;user=;password=;DBPATH= ;USEV5SERVER=1


    The last parameter in the URL has to be specified if you use version 5 of the product.
    rws

  3. #3
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    Why don't you just answer me in the forum?

    Did you try it with the DBPATH variable?
    rws

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •