Results 1 to 9 of 9
  1. #1
    Join Date
    Jan 2003
    Posts
    15

    Unanswered: slow LOCAL access with EM on MSSQL 2000 - extensive disk usage...

    Hallo,
    I have strange problem - since some date I have a very very slow response from my LOCAL MSSQL when using Enterprise Manager or for example Query Analyzer. In fact it seems to me all locally used tools would do the same. The slow response means that I am waiting for any action about 1-5 minutes with very extensive disk usage and nearly none CPU usage. Any local aplication I am developing have no problem - its queries are fast enough like before. The strangest thing is that when I am using Enterprise Manager from another client to connect and manage my LOCAL MSSQL, i have no such a problem, everything goes smoothly like it should. I have set-uped that only TCP-IP connection are allowed to connect my MSSQL.

    It seems to me it might be some problem with Authentification?? (mixed authentification is allowed on my MSSQL. But why it is normally fast when connecting from another computer and why so slow when using LOCAL computer??

    sorry fr my english, thanks for any hits

  2. #2
    Join Date
    Nov 2002
    Posts
    24

    Arrow

    I don't think that its an authentication problem because you are obviously able to log in locally.

    If you have not installed the latest service pack then do so you may have a buggy installation and this may do the trick.
    TECMAN

  3. #3
    Join Date
    Jan 2003
    Posts
    15
    no, I have few days old instalation (in fact, re-instalation) - before it there was tha same problem. SP2 also didnt help. Still slow local acces from EM with extensive disk usage...

  4. #4
    Join Date
    Nov 2002
    Posts
    24
    Check in enterprise manager (processes) to see what type of net library you are using when using query analyzer.

    What server pack is running on your 2000 box is it service pack 3 if not you should upgrade this also.
    TECMAN

  5. #5
    Join Date
    Jan 2003
    Posts
    15
    SP3 ? I didnt find it. Have SP2, on microsoft's www there only sp2. And how to check which protocol is EM using through Processes? Sorry, i am little bit confused. In fact, I enabled only TCP/IP protocol on my server. I tryed to add alias to client network utility of type TCPIP and connect to my local mssql through it, but no improvement on my problem...

    still dont know...

    thanks for your hits !

  6. #6
    Join Date
    Nov 2002
    Posts
    24
    Try this. Un register your local server in enterprise manager. Then reregister is using the "." or "local" (no quotes "")this should force the use of local named pipes.

    Check to see if you are using the latest version of MDAC see
    http://www.microsoft.com/data/download.htm

    and download mdac sp3 release.
    TECMAN

  7. #7
    Join Date
    Jan 2003
    Posts
    15
    In fact I have disabled using of any other protocol then TCP-IP. I need it because my server. But it worked normally, so I sont think thats reason of my problem.

    I am running MSSQL2000 developer version on MS XP proffesional, so MDAD SP3 cannot be installed here.

    Nothing helped me till now, really dont know what to do. In fact, I am rather connecting to my mssql server from another computer, because it works perfectly. But its a little bit hard work. I am also using VMWARE using W98 and enterprise manager on the local computer, and it also work perfectly. So I am nearly close to say something is wrong when connection to mssql or what....

  8. #8
    Join Date
    Feb 2004
    Posts
    1

    Solving why mssql server is runing so slowling while extenisive disk usage

    Hi

    Probably this is set in your odbc.


    go to control panel, admiistrative tools, Data Sources(odbc)

    Now in the ODBC data source adminstrator, choose the Tracing (tab)

    Stop The Tracing Now.

    Hope this solve your problem.......


    It surely did help me....

  9. #9
    Join Date
    Jan 2003
    Posts
    15

    Re: Solving why mssql server is runing so slowling while extenisive disk usage

    Hi,
    yes it helped. I have found it few month ago, sorry that I did not reply to this board sooner... but thanks anyway, somebody with similar problem will be glad for you answer, me aswell, because i am sure next time it will happens to me, i wont be remember what to do

    have a nice day

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •