Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2003
    Location
    Wiltshire, UK
    Posts
    5

    Unanswered: Installing MDAC 2.5 on W2k sp3

    I have tried installing MDAC 2.5 on a w2k sp3 machine and it fails with the following error:

    Microsoft Data Access components 2.5 is already installed on the version of windows you are running. Setup cannot update the system. For more information ......

    BUT, Mdac 2.5 is not installed on the machine and VB applications using it do not work.

    Any ideas?

    Thank
    Attached Thumbnails Attached Thumbnails adoerror.bmp  

  2. #2
    Join Date
    Oct 2002
    Posts
    369

    Re: Installing MDAC 2.5 on W2k sp3

    Q1 Any ideas?

    A1 Yes.

    1 Check your MDAC component status with the compatibility checking tool. See:

    http://www.microsoft.com/data/download.htm#CCinfo

    http://download.microsoft.com/downlo...P/EN-US/cc.exe

    2 See MDAC Installation Notes at: http://msdn.microsoft.com/library/de...dacinstall.asp

  3. #3
    Join Date
    Jan 2003
    Location
    Wiltshire, UK
    Posts
    5
    Thanks DBA,

    This has let me discover that the latest PCs with W2k have sp3 installed by default which includes MDAC 2.6. It is therefore not possible to install MDAC 2.5 - it physically stops you.

    It just means I have to change the references to the ADO 2.5 objects to 2.6...

  4. #4
    Join Date
    Oct 2002
    Posts
    369
    You are most welcome.

    Hopefully 2.6 is otherwise fully compatible with your applications. Newer (and sometimes corrupt or third party) dll issues are not an uncommon source of spurious "already installed" and similar MDAC errors.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •