Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2003
    Location
    London
    Posts
    1

    Unanswered: ORACLE 9i ODBC Error

    I have just installed ORACLE 9i (Release 2 (9.2.0.1.0)) on a Windows2000 server and all is working fine except for the ODBC drivers.

    When setting up a system DSN for my data source using the 'ORACLE in OraHome92' driver I receive the following error:

    Unable to Connect
    SQLState=IM004
    error:[Microsoft][ODBC Driver Manager] Driver's SQLAllocHandle on SQL_HANDLE_ENV failed.

    If anyone has come acroos anything similar I would appricate any help.

  2. #2
    Join Date
    Dec 2003
    Posts
    5

    Re: ORACLE 9i ODBC Error

    Originally posted by pwill53
    I have just installed ORACLE 9i (Release 2 (9.2.0.1.0)) on a Windows2000 server and all is working fine except for the ODBC drivers.

    When setting up a system DSN for my data source using the 'ORACLE in OraHome92' driver I receive the following error:

    Unable to Connect
    SQLState=IM004
    error:[Microsoft][ODBC Driver Manager] Driver's SQLAllocHandle on SQL_HANDLE_ENV failed.

    If anyone has come acroos anything similar I would appricate any help.
    Yeah, have this problem too, noticed that by making the user a local admin on the W2k box solved the problem, not a great idea in a all cases. but if you find any more info please pass it on.

  3. #3
    Join Date
    Nov 2003
    Location
    Bangalore, INDIA
    Posts
    333

    Thumbs up

    Hi,

    Make sure that the 9.2 oracle home/bin directory is in the system path statement. Also make sure that the user that is logged in has permission to read and execute on that directory.
    SATHISH .

  4. #4
    Join Date
    Dec 2003
    Posts
    5

    Thumbs up re: ORACLE 9i ODBC Error

    Thanks satish_ct, I eventually found an article on www.Metalink.oracle.com, that basically expands on what you said.

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •