Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2003
    Location
    Scotland
    Posts
    2

    Question Unanswered: Strange Informix Issue - Help Appreciated

    Hi,

    Apologies for the crosspost, this has already been posted on to USENET.

    I'm grappling with a significant Informix issue and would be grateful if someone could offer me advice.

    We are running IDS 9.30 UC1 on Solaris / Sun Cluster 3.0 with unbuffered logical logging. Our database has gone down due to the fact that our automated backup of the logical log files (via ontape) has failed. All 50 logs are 100% full and we have been unable to force a checkpoint.

    Investigation via oncheck -pe uncovered an error in a dbspace/BLOBspace called, originally enough, 'blobspace'. This error appears to have stopped the ontape backup from running successfully. 'Blobspace' is a 2048 KB (2K page x 1024 pages) cooked file called tblob, containing a single chunk, which is targeted via a link as per Informix Admin Guide recommendations. The other six dbspaces are all raw spaces as they contain critical data, the cooked file only holds transient, unimportant data.

    The error is of the form ERROR:Bad bfget for page 0xa00000

    To rectify this we tried using onmonitor to drop the the BLOBspace and its associated chunk, on the premise that we would then be able to backup the logical logs and resurrect the database. No success, onmonitor seemed to hang completely and required a kill -9 from another terminal.

    We tried onspaces -d to both drop the chunk from the BLOBspace (I didn't expect this to work) and the entire BLOBspace. Again no success, the following error was returned:

    Cannot drop the space.
    ISAM error: Primary and Mirror chunks are bad

    This was a bit strange as we are not using Informix mirroring!

    Our next recourse was to attempt to add an additional chunk to 'blobspace' via onmonitor. No success. We also tried deleting and remaking the cooked file and the associated link file via both onmonitor and onspaces, all as per Admin Guide. No success, we get messages which tell us that the file / chunk already exists.

    Our current situation is that we cannot seem to do anything with this particular BLOBspace, and until we can resolve the error, we cannot backup our logical logs to get the database online.

    Has anyone else been caught in this Catch 22 situation? Can anyone shed some light on the issue? And do you have any suggestions to help me get out of this mess whilst I still have a few hairs left on my head?

    Any assistance would be most appreciated.

  2. #2
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    What does onstat -d show you?
    Is the dbspace marked down?

    What happens if you kill the symbolic link? Can you then drop the chunk?
    rws

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •