Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2003
    Posts
    2

    Unanswered: ORA-12545 error but can tnsping

    i am getting the error. . .

    Connecting...ORA-12545: Connect failed because target host or object does not exist
    The test did not succeed.

    . . .when trying to test the tnsnames.ora entry i created using net8 config assistant.

    i am able to tnsping the net service name that i created (even though the net8 test failed).

    so. . .

    it appears that the listener is listening (tnsping success), but i can't make a connection to this service name (either odbc or sqlplus).

    additionally: i am connecting to this server through a vpn. we are running sonicwalls on both sides. could this be causing the problem?

    any thoughts?

    thanks in advance,
    ben.

  2. #2
    Join Date
    Oct 2002
    Location
    greenwich.ct.us
    Posts
    279

    Re: ORA-12545 error but can tnsping

    Originally posted by bisenhour
    additionally: i am connecting to this server through a vpn. we are running sonicwalls on both sides. could this be causing the problem?
    Could be. You may need to run a connection manager or a SQL*Net proxy so your requests go in and out of the same port. You'd have to sniff your network to see where your packets are going.

    However, it may be as simple as a misconfigured tnsnames.ora or listener.ora. Does this connection work without the firewalls involved?

  3. #3
    Join Date
    Jan 2003
    Posts
    2
    yes, i can connect to a 8.1.7 database that's on the local network without a problem.

    here is some more info. . .

    i have four databases that i want to connect to from my 8.1.7 client:

    1) in network 8.1.7 database (mentioned above), this works just fine

    2) across 56k frame relay (pvc) 8.0.6 database, this works just fine

    3) across 56k frame relay (pvc) 8.1.7 database, getting the error:
    Connecting...ORA-12545: Connect failed because target host or object does not exist

    4) across vpn (sonicwall firewall) to 8.1.7 database, getting the error:
    Connecting...ORA-12545: Connect failed because target host or object does not exist

    in both 3 and 4 i can tnsping the servicenames that i set up in net8 config.

    any more thoughts?

  4. #4
    Join Date
    Oct 2002
    Location
    greenwich.ct.us
    Posts
    279
    Originally posted by bisenhour
    1) in network 8.1.7 database (mentioned above), this works just fine

    3) across 56k frame relay (pvc) 8.1.7 database, getting the error:
    Connecting...ORA-12545: Connect failed because target host or object does not exist


    Hmm. Same database in #3 as in #1? If so, the client side tnsnames.ora or sqlnet.ora might be wrong. If they're different, test client that is local to #3 without pvc link.


    in both 3 and 4 i can tnsping the servicenames that i set up in net8 config.
    tnsping tells half-truths.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •