I'm currently running an apache_2.0.43-win32-x86-no_ssl server, with php-4.2.3, mysql max 3.23.52, and ActivePerl-5.6.1.633-MSWin32-x86; When I go to the Command Prompt, then type in "ppm<enter>", then type "install DB_File", I get the following

"Error installing package 'DB_file': Read a PPD for 'DB_file', but it is not intended for this build of Perl (MSWin32-x86-multi-thread)"

Can someone explain this to me please, I've used this build of Perl before, and Apache, the only thing I can think of is that I'm using Win-doze XP Home, instead of Professional. I dont know much about Perl, if you can't tell, and was looking into all kinds of solutions on the internet, but I'm getting more lost than I was before. Help???