Results 1 to 3 of 3

Thread: Ribo Utility

  1. #1
    Join Date
    Jan 2003
    Posts
    2

    Angry Unanswered: Ribo Utility

    I'm trying to capture sql going into an ASE 12.5 server using Ribo. I can run the executable but cannot seem to capture anything.There must be something I'm missing....

  2. #2
    Join Date
    Jun 2002
    Location
    Argentina
    Posts
    78

    Thumbs up

    Rivo is a very nice utility but you must configure your client to connect to the machine where RIBO run.
    I use this bat in win2000 to run RIBO.

    @echo off
    SETLOCAL
    set RIBO_HOME="C:\sybase\ribo"
    set JAVA_HOME="C:\Archivos de programa\Sybase\Shared\Sun\jdk118"
    java -classpath "C:\sybase\ribo\ribo.jar;." com.sybase.ribo.RiboMgr -gui -l 4100 -s 70.101.0.9 -p 4100 -t
    ENDLOCAL

    RIBO is listening in the port 4100 and redirect to the server with the IP 70.101.0.9 and port 4100
    Don’t forget to add RIBO into the client with "dsedit" or edit sql.ini (win) or interfaces (Unix), so the client will see RIBO, and of course if you use isql (or an aplication) you must connect to this new server.
    Finally, don’t forget to push button of start listening (sometime I forget)
    Good luck !!!

    Sebastian

  3. #3
    Join Date
    Jan 2003
    Posts
    2

    Thumbs up Got it!

    Thanks, that was the piece I needed. It's working fine now!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •