Results 1 to 3 of 3
  1. #1
    Join Date
    Feb 2003
    Posts
    2

    Unanswered: sqlhosts nightmare

    Hello,

    I am trying to set up an informix database on an SGI system for benchmarking purposes only. I will be connecting from the same location where the database server is kept and the only user will be the informix user.

    I cannot get the sqlhosts file settings correct so I can run oninit -iy

    my settings look like this

    bench_tcp onipcshm Origin3000 turbo

    My onconfig.bench shows:

    DBSERVERNAME bench_tcp
    DBNAME bench

    No matter what I do, I get an error when starting oninit that states the following:

    error: Unable to locate DBSERVERNAME Origin3000 in sqlhosts file or the sqlhosts file is corrupted.

    ANY help that can be offered will be greatly appreciated!!

    Thanks!!

  2. #2
    Join Date
    Aug 2002
    Location
    Bonn/Germany
    Posts
    152
    The problem seems to be that your $INFORMIXSERVER
    environment variable points to 'Origin3000'.
    Reset your $INFORMIXSERVER env variable to
    'bench_tcp' and then try again.

    Anyway the names you have choosen are not optimal:

    bench_tcp onipcshm Origin3000 turbo

    I would suggest that you change your entries like
    this:

    1) sqlhosts entries
    --------------------
    bench_tcp ontlitcp Origin3000 bench_tcp
    bench_shm onipcshm Orign3000 bench_shm

    2) $ONCONFIG entries
    --------------------------
    DBSERVERNAME bench_shm
    DBSERVERALIASES bench_tcp

    3) export INFORMIXSERVER=bench_shm

    4) Add service 'bench_tcp' to your /etc/services file


    Now you have configured two connections (one local using
    shared memory ipc) and one for remote clients (using tcp).
    Then shared memory connection will be faster, but can only
    be used for local clients.
    You need also to lookup the correct protocol in your
    IFMX releasenotes. (it could be 'ontlitpc' or 'onsoctcp').
    This is platform dependend.

    HTH.

    Best regards

    Eric
    --
    IT-Consulting Herber
    WWW: http://www.herber-consulting.de
    Email: eric@herber-consulting.de

    ***********************************************
    Download the IFMX Database-Monitor for free at:
    http://www.herber-consulting.de/BusyBee
    ***********************************************

  3. #3
    Join Date
    Feb 2003
    Posts
    2

    thanks!

    I thought that too about the environment variable..but it wasn't true. I looked and looked and could never come up with what was causing the system to think that my DBSERVERNAME was suppose to be Origin3000.
    (the server name was a residual from my attempts to try to set it up with tcpip teletype)

    I finally found the correct syntax at about 5pm today. I left my sqlhosts file the same but added a root path and the correct nettype in my config.bench file.

    I've been workign on this all night, and as we speak I have the database finally LOADING!!

    I will come back tomorrow when I have a clearer head and post the details of the settings that worked. (After I solved this issue the geodetic blade module and table spaces started choking!)

    Thanks for your reply....

    Tess

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •