Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2003
    Posts
    24

    Exclamation Unanswered: ORA-00406: COMPATIBLE parameters needs to be 8.1.0.0.0 or grater

    An application creates dinamically tables, triggers, packages, etc.

    It works correctly with Oracle 8.1.6, but It doesn't work with Oracle 8.1.7.

    This is the error message:
    ORA-00406: COMPATIBLE parameters needs to be 8.1.0.0.0 or grater.

  2. #2
    Join Date
    Sep 2002
    Location
    UK
    Posts
    5,171
    Provided Answers: 1

    Re: ORA-00406: COMPATIBLE parameters needs to be 8.1.0.0.0 or grater

    Originally posted by nmoreno
    An application creates dinamically tables, triggers, packages, etc.

    It works correctly with Oracle 8.1.6, but It doesn't work with Oracle 8.1.7.

    This is the error message:
    ORA-00406: COMPATIBLE parameters needs to be 8.1.0.0.0 or grater.
    The answer is staring you in the face. There is a database parameter called COMPATIBLE that is used for backwards compatibility. Your 8.1.7 database apparently has this set to a LOWER value than 8.1.0.0.0, e.g. 8.0.9.0.0, which was a version of Oracle that didn't support whatever it is you are trying to do.

    The solution is to update the COMPATIBLE parameter to a higher value. This is something the DBA has to do for you.

  3. #3
    Join Date
    Jan 2003
    Posts
    24
    Thanks for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •