Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2003
    Posts
    1

    Red face Unanswered: Ora-12154 Connecting to WebServer

    I have a web application on a Win2K web server connecting to an Oracle 8 database.
    When I access the site from the web server i.e. http://localhost/site it works correctly.

    When I attempt to access the site from a remote client i.e. http://<servername>/site
    I get the following error
    "Error while trying to retrieve text for error ORA-12154"

    This seems to be a configuration issue since local connections work and remote connections don't.

    Does anybody have any suggestions on this issue?

    Thanks a bunch!

  2. #2
    Join Date
    Jan 2003
    Location
    Woking
    Posts
    107

    Re: Ora-12154 Connecting to WebServer

    Originally posted by dgodwin
    I have a web application on a Win2K web server connecting to an Oracle 8 database.
    When I access the site from the web server i.e. http://localhost/site it works correctly.

    When I attempt to access the site from a remote client i.e. http://<servername>/site
    I get the following error
    "Error while trying to retrieve text for error ORA-12154"

    This seems to be a configuration issue since local connections work and remote connections don't.

    Does anybody have any suggestions on this issue?

    Thanks a bunch!
    Hi,
    I think this is because, there is no TNS entry for that particular,
    Oracle database in the tnsnames.ora file.(on the web server)
    You should make the entry in the web server.
    If you are able to connect from your local machine, then
    copy that TNS entry from your local machine's tnsnames.ora file
    and add it to the tnsnames.ora file in your web server.

    Hope it helps.
    nn

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •