Results 1 to 2 of 2
  1. #1
    Join Date
    May 2002
    Location
    Italy
    Posts
    36

    Red face Unanswered: Vacum With auth_type = password Error

    Hi,

    my problem is this, i configured my ph_hba as this:

    #Type DB Ip_add Netmask auth_type auth_argu.

    host all 192.168.1.0 255.255.255.0 password "password file"

    After one week i know that in postgres i necessary use every night "vacumm full" because i one week my db was become 1Gb, i think is to much. Than i put in crontab of postgres user this command
    "0 1 * * * /(path)/psql -q -c "vacuum full" dbname
    but at 1 o'clok arrive a mail to postgres user that tell
    "No pg_hba.conf entry for host localhost, user "postgresuser", database "dbname"

    I tested this command in text mode and it's ok, i think that the problem is in password. How can a put the password in psql parameters!

    Why!

  2. #2
    Join Date
    Sep 2001
    Location
    Vienna
    Posts
    400

    2 options

    1
    you don't set a password from local connects

    2
    make perl script that connects to the db and runs vacuum


    maybe with a shell script you can send the password, but there is no parameter for the password
    http://www.postgresql.org
    --Postgresql is the only kind of thing--

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •