Results 1 to 4 of 4

Thread: Adding a system

  1. #1
    Join Date
    Feb 2003
    Location
    Slovenia
    Posts
    2

    Unanswered: Adding a system

    When I try to search for another DB2 system (with wizard) I get this error:
    SQL30081N A communication error has been detected. Communication protocol being used: "TCP/IP". Communication API being used: "SOCKETS". Location where the error was detected: "". Communication function detecting the error: "connect". Protocol specific error code(s): "10054", "*", "*". SQLSTATE=08001
    while trying to specify it (I'm trying to add a system that is installsed on Linux to be accessible from WIN2000).

    Can anyone please give me some advice on this.

  2. #2
    Join Date
    Oct 2001
    Location
    Bangalore
    Posts
    186
    Hi,

    Check if both the systems are on Network.
    If yes then try to catalog the node giving the IP of the machine instead of machine name.

    This should work, let us know the results.

    Cheers,
    Prashant

  3. #3
    Join Date
    Sep 2002
    Posts
    456

    Re: Adding a system

    check that the db2comm parameter is set to use TCPIP protocol on server side; issuse db2set command and see if there is an entry for db2comm. Make sure that you can ping the host from your client. Also make sure that the dbm cfg parameter svcename is set to the appropriate service name as specified in your /etc/services file.

    dollar

    Originally posted by Nanook
    When I try to search for another DB2 system (with wizard) I get this error:
    SQL30081N A communication error has been detected. Communication protocol being used: "TCP/IP". Communication API being used: "SOCKETS". Location where the error was detected: "". Communication function detecting the error: "connect". Protocol specific error code(s): "10054", "*", "*". SQLSTATE=08001
    while trying to specify it (I'm trying to add a system that is installsed on Linux to be accessible from WIN2000).

    Can anyone please give me some advice on this.

  4. #4
    Join Date
    Feb 2003
    Location
    Slovenia
    Posts
    2
    Thanks for your help. I managed to solve problem. It turned out thet network administrator was a little bit too much consrned for our network security and has closed a few ports unknown to him, before leaving for a few days, and of course, he told noone about that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •