Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2003

    Unanswered: Phantom database?

    I restored a database to v7.2 on XP from a backup made from another version (v7.1) on Windows98. It worked! Then I decided to delete it and attempt the restore again. Big mistake. I received SQL1005N saying it already existed. When I tried to uncatalog it from the the system I received SQL1013N state=42705 saying the database could not be found. How does the restore operation know about it when the other operations clearly don't? I don't really want to reinstall DB2 as I view it's instatllation a bit of a miracle in itself. Any help or ideas would be greatly appreciated.


  2. #2
    Join Date
    Aug 2001

    Re: Phantom database?


    db2 list db directory


    db2 list db directory on C:\

    IF the database appears in the second listing, do

    db2 catalog database <dbname> on C:\

    and then do a db2 drop database ....

    BTW, did you DROP DATABASE command ? or was it a delete of the directories ?



  3. #3
    Join Date
    Jan 2003
    Hi Sathyaram

    Thank you, you solved the problem! But as usual it leads me to another one. I can't seem to eliminate a SQL117N - Connection or activation problems due to a pending forward roll. I've been reading contradicting information from IBM. I'm going to try a few approaches gleaned from responses to the same problem posted on this site.

    Thanks again,



    1. The original problem occurred after I issued a drop database.
    2. I had to remove the "\" from "db2 catalog database <db> on C:\" before it would catalog.
    Last edited by johnkippers; 03-03-03 at 16:32.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts