Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2002

    Unanswered: end-of-file on communication channel....

    help...I got an "ORA-03113: end-of-file on communication channel" error

    when performing a shutdown immediate.

    when I tried to issue the statement again, I got a
    "ORA-24324: service handle not initialized"

    after checking the most recent trace file I found this statement

    "*** SESSION ID9.260) 2003-03-05 01:08:55.000
    Skipped error 604 during the execution of INTE01.TR_LOGON
    *** 2003-03-05 01:08:56.000
    ksedmp: internal or fatal error
    ORA-00604: error occurred at recursive SQL level 1
    ORA-04092: cannot COMMIT in a trigger
    ORA-06512: at line 6"

    this is Oracle 9i release 2 on XP

    pls. help!!!
    Last edited by Wale; 03-05-03 at 01:37.

  2. #2
    Join Date
    Dec 2002

    The "ORA-04092: cannot COMMIT in a trigger" is the real error.

    You must solve that one first.

    Where the "ORA-03113: end-of-file on communication channel" comes from ? I don't know...

    Whenever you are sure that you want to commit in the trigger you'll have to tell oracle to spawn a autonomous transaction in your trigger.

    pragma autonomous_transaction;

    Hope this helps!!

    Remi Visser

    Oracle Database Administrator
    (OCP certified 8i)


  3. #3
    Join Date
    Mar 2002
    Thanks. I actually rebooted the Machine and then Logged on to using "connect logon as sysdba"
    I then did a shutdown abort and it worked.
    I went in and found the trigger and disabled it.
    thanks for the autonomous transaction hint
    I am happy now

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts