Results 1 to 10 of 10
  1. #1
    Join Date
    Mar 2003
    Posts
    43

    Question Unanswered: MSDE won't respond

    I'm trying to set up MSDE to use for learning ASP.NET but it won't cooperate. The first thing I tried was to secure the "sa" account acording to the instructions on this page, but when I try

    osql -U sa

    ... and then enter a blank password (that's the default right?) I get the following:
    [Shared Memory]SQL Server does not exist or access denied.
    [Shared Memory]ConnectionOpen (Connect()).
    I'm using Windows XP Professional and my MDAC version is 2.7.

  2. #2
    Join Date
    May 2002
    Posts
    299

    Re: MSDE won't respond

    To connect successfully, sqlserver service must be running. You might want to check to make sure it's started.
    --
    -oj
    http://www.rac4sql.net

  3. #3
    Join Date
    Mar 2003
    Posts
    43
    OK, I did actually have a service called "SQLSERVERAGENT" and when I started that (you would think it would start automatically after install), I got a little further. But now I get "User 'sa' not associated with a trusted connection" or something like that (translation from swedish). I remember getting this error in SQL Server 2000 one time, and I had to change the authorisation from Windows to SQL Server, but how do I do that with MSDE?

    Thanks in advance!

  4. #4
    Join Date
    Sep 2002
    Location
    MI
    Posts
    19

    Do not use msde database

    Please considering using the nothwind database or create new. This will cause major SQL Server Problems.
    Jon Nelson

  5. #5
    Join Date
    Mar 2003
    Posts
    43
    Yes, I will create a new db, but I was recommended to change the password for the "sa" account, and that's what I'm trying to do.

  6. #6
    Join Date
    Mar 2003
    Posts
    43
    forgot attachment...

  7. #7
    Join Date
    Mar 2003
    Posts
    43
    On the page I linked to in my first post, they explain how to change authentication to mixed mode, but the registry key they reference to doesn't exist in my registry.

    Their path is:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\Instance Name\MSSQLServer\

    Here's my structure, and the key "LoginMode" is nowhere to be found.
    Attached Thumbnails Attached Thumbnails msqltree.gif  

  8. #8
    Join Date
    May 2002
    Posts
    299
    Unless you're going to use SQL login, there is no need to change it to mixed mode. If you want to change the password for 'sa', just execute the following at dos prompt

    osql -Q"exec sp_password null,'newpassword','sa'" -E

    You could download QALite from our site if you want a GUI instead of osql command tool.
    --
    -oj
    http://www.rac4sql.net

  9. #9
    Join Date
    Mar 2003
    Posts
    43
    Thanks guys! I got it working because the reg key suddenly appeared and I was able to change to mixed authentication and change the password for 'sa'.

    However, to create an account with limited permissions for use with my ASP.NET applications I'd like to know if there is a tool that could be used for that, or maybe an article about OSQL? I've never used OSQL before, and I'm having trouble finding information about it.

  10. #10
    Join Date
    May 2002
    Posts
    299

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •