Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2003
    Posts
    3

    Unanswered: Error in getting DB2 connection from WebSphere 5.0

    Hi,

    I created a DataSource (type 5) in WebSphere 5.0 and trying to access DB2 UDB 8.1. I am getting the following error

    "SRVE0026E: [Servlet Error]-[SQLConnect]: java.lang.UnsatisfiedLinkError: SQLConnect at COM.ibm.db2.jdbc.app.DB2Connection.SQLConnect" stacktrace follows..

    Both Application Server and Database are on the same machine. Do I need to have DB2 client also on the same machine to access database. I am referring to the COM.ibm.db2.jdbc.DB2ConnectionPoolDataSource driver from db2java.zip available at java12 folder of SQLLIB.

    Classpath: /export/home/hdwiadm1/sqllib/java12/db2java.zip where /export/home/hdwiadm1 is installation directory.

    I will be very thankful if somebody guide me.

    Regards,
    Naveen.

  2. #2
    Join Date
    Feb 2002
    Location
    Germany
    Posts
    141
    I've not installed V8.1, read my suggestions with care ;-)

    First, you don't need the DB2 Client on the Server Machine.
    Second, it seems that you are using the wrong .zip file! Take the one from /export/home/hdwiadm1/sqllib/java/ instead.
    Third, you should run usejdbc2 (stop db2 first, or you will get an error), for using ConnectionPooling.

    But, as I've said, I cannot give you any guarantee...
    Rodney Krick

  3. #3
    Join Date
    Mar 2003
    Posts
    3

    Thanks for the suggestion

    Thanks for the suggestions. Instead of Type 2 driver, I am planning to use Type 4 driver.

    Regards,
    Naveen.

  4. #4
    Join Date
    Nov 2004
    Posts
    1
    my env:
    aix was5.1 db2client ver 7.x

    try and run /slqlib/java12/usejdbc2.bat it may help

    it tells db2 to use jdbc2/installs some files

    recycle WAS.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •